Highlighted
rsadmin86
1 Copper

Avamar VM backup fails

Jump to solution

I am having a very odd problem in my vSphere 6.5 update 1 environment. When i try to run a on-demand backup, i see the snapshot being taken by the avamar user i setup in vSphere. However after 5 seconds the snapshot is removed and the backup fails. I am using Avamar version 7.1.2-21 and the proxy is version 7.1.102-21. I have verified the following:

1) nslookup of the host from the proxy is successful

2) port 443 is open to the vCenter, and port 902 is open for the host. I verified this by using the curl -kv command from the proxy to the host

3) I can log into vSphere as the avamar user, Storage vMotion, take multiple snapshots, and remove snapshots.

4) as the avamar user i am able to navigate to the VM files in the datastore

5) The avamar user has full admin rights at the highest level and is propagated down

This is the errors I am seeing:

2017-12-26 11:08:03 avvcbimage Error <0000>: [IMG0008] Failed to connect to virtual disk [DataStore2] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmdk (13) (13) You do not have access rights to this file (Log #1)
2017-12-26 11:08:03
avvcbimage Error <0000>: [IMG0008] VixDiskLib_Open([DataStore2]] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmdk) returned (13) You do not have access rights to this file (Log #1)
2017-12-26 11:08:04
avtar Info <7202>: Backup CANCELED, wrapping-up session with Server (Log #2)
2017-12-26 11:08:05
avvcbimage Error <0000>: [IMG0011] Avtar exited with 'code 163: externally cancelled' (Log #1)
2017-12-26 11:08:05
avtar FATAL <0000>: Backup 'MOD-1514304411263' to DDR not sealed due to previous errors2017-12-26 11:08:05 avtar Info 0000>: Entering the 'final' phase of termination, Fatal error enountered) (Log #2)
2017-12-26 11:08:05
avtar FATAL <5155>: Backup aborted due to earlier errors. No backup created on the server. (Log #2)
2017/12/26-16:08:04.57942
avtar DEBUG-ERROR <0001> backstreamdir::childdone error merging history stream data during phase_do_hidden while processing directory 'VMFiles/ForceError-0' (Log #2)
2017/12/26-16:08:04.69779
avtar DEBUG-ERROR <0001> backstreamdir::childdone error merging history stream data during phase_do_hidden while processing directory 'VMFiles' (Log #2)
2017/12/26-16:08:05.78554
avtar DEBUG-ERROR <0001> backstreamdir::childdone error merging history stream data during phase_do_hidden while processing directory '' (Log #2)



I also see this which I thought was weird:


2017-12-26 11:07:18 avvcbimage Info <0000>: [IMG0009] Pre-snapshot script: completed successfully

2017-12-26 11:07:18 avvcbimage Info <9692>: a VM snapshot has been requested

2017-12-26 11:07:18 avvcbimage Info <14627>: Creating snapshot 'Avamar-1514304438dd479ddf05179a0e24945b8011b1dfc61a1eb87e', quieceFS=1

2017-12-26 11:07:18 avvcbimage Info <14631>: Snapshot 'Avamar-1514304438dd479ddf05179a0e24945b8011b1dfc61a1eb87e' creation for VM '[DataStore2] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmx' task still in progress, sleep for 2 sec

2017-12-26 11:07:20 avvcbimage Info <14631>: Snapshot 'Avamar-1514304438dd479ddf05179a0e24945b8011b1dfc61a1eb87e' creation for VM '[DataStore2] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmx' task still in progress, sleep for 2 sec

2017-12-26 11:07:22 avvcbimage Info <14631>: Snapshot 'Avamar-1514304438dd479ddf05179a0e24945b8011b1dfc61a1eb87e' creation for VM '[DataStore2] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmx' task still in progress, sleep for 2 sec

2017-12-26 11:07:24 avvcbimage Info <14631>: Snapshot 'Avamar-1514304438dd479ddf05179a0e24945b8011b1dfc61a1eb87e' creation for VM '[DataStore2] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmx' task still in progress, sleep for 2 sec

2017-12-26 11:07:26 avvcbimage Info <14632>: Snapshot 'Avamar-1514304438dd479ddf05179a0e24945b8011b1dfc61a1eb87e' creation for VM '[DataStore2] VM_TEST_WORKSTATION/VM_TEST_WORKSTATION.vmx' task completed, moref=snapshot-138

2017-12-26 11:07:26 avvcbimage Info <19680>: vmAction runBackupScript: ()

2017-12-26 11:07:26 avvcbimage Info <19681>: vmAction runBackupScript: script is skipped because it is null

2017-12-26 11:07:26 avvcbimage Info <0000>: [IMG0009] Post-snapshot script: completed successfully



Anyone have any suggestions?

Reply
1 Solution

Accepted Solutions
Highlighted
ionthegeek
4 Beryllium

Re: Avamar VM backup fails

Jump to solution

Support for vSphere 6.5 was added to Avamar version 7.4.1-58:

CompGuideApp

You will need to schedule an upgrade to ensure stable backups of your vSphere 6.5 environment.

View solution in original post

Reply
4 Replies
Highlighted
ionthegeek
4 Beryllium

Re: Avamar VM backup fails

Jump to solution

Support for vSphere 6.5 was added to Avamar version 7.4.1-58:

CompGuideApp

You will need to schedule an upgrade to ensure stable backups of your vSphere 6.5 environment.

View solution in original post

Reply
Highlighted
Sanspy
1 Copper

Re: Avamar VM backup fails

Jump to solution

Hyperlink is inaccesible

Reply
ionthegeek
4 Beryllium

Re: Avamar VM backup fails

Jump to solution

Working for me. I recommend clearing your cache and cookies, then making sure you're signed into your Dell EMC account.

Reply
Highlighted
Anil_2009
1 Copper

Re: Avamar VM backup fails

Jump to solution

Verify that the vCenter user has all required privileges

Download the latest version of proxycp.jar script ftp://avamar_ftp:anonymous@ftp.emc.com/software/scripts/proxycp.jar"

Copy the script to the Avamar server in /home/admin directory.

Run this command: java -jar /home/admin/proxycp.jar --listpermission

Install one of the below hotfixes which upgrades the VDDK version on the proxy to v5.5 U3

- Avamar proxy v7.0 SP2 (Hotfix 195585)

- Avamar proxy v7.1 (Hotfix 202153)

Reply