Highlighted
davidoc1
1 Nickel

Bare Metal Restore SQL services not starting

Jump to solution

We recently had to do a bare metal restore of a sql server and the VSS/Windows file system restores seem to complete successfully, but once we log in to the restored VM, the SQL services will not start.  We've tried it again with a different SQL vm and it has the same issue.

We get an error code 17113 when trying to start the sql server service.

VMware 5.5

Windows Server 2012 R2

SQL server 2014

We are not using SQL plugin and are wondering if that is causing the issue.

0 Kudos
1 Solution

Accepted Solutions
8 Krypton

Re: Bare Metal Restore SQL services not starting

Jump to solution

A Bare Metal Restore will restore all the binaries required for a service but not necessarily the data. I did some quick research and it looks like this message most often shows up if master.mdf is missing or damaged.

If you're not using the SQL plugin, this file is probably not being backed up. Even if it is being backed up, there's no guarantee it's being backed up in a consistent state. I suspect you are correct that the cause of the issue is that you're not backing up using the SQL plugin.

0 Kudos
3 Replies
davidoc1
1 Nickel

Re: Bare Metal Restore SQL services not starting

Jump to solution

Avamar 7.3 with DataDomain 5.6

0 Kudos
8 Krypton

Re: Bare Metal Restore SQL services not starting

Jump to solution

A Bare Metal Restore will restore all the binaries required for a service but not necessarily the data. I did some quick research and it looks like this message most often shows up if master.mdf is missing or damaged.

If you're not using the SQL plugin, this file is probably not being backed up. Even if it is being backed up, there's no guarantee it's being backed up in a consistent state. I suspect you are correct that the cause of the issue is that you're not backing up using the SQL plugin.

0 Kudos
davidoc1
1 Nickel

Re: Bare Metal Restore SQL services not starting

Jump to solution

Thanks Ian, I did a test backup/restore with the SQL plugin installed and the SQL services appear to be starting properly after bare metal restore.

My apps people do not want to install the SQL plugin on our SQL servers (they said they have tried it before and it caused their apps to become extremely slow), but it appears that we will have to if we want to use Avamar to back them up.

0 Kudos