Watcharin
1 Copper

Can't browse Oracle Database from Avamar GUI

Hi, all

I currently POC Avamar with Data Domain with Oracle 11g (Solaris Sparc)

I deployed Solaris Avamar agent then Solaris RMAN Agent all went fine.

because This server just Test/Dev oracle so it's stand-alone server so I can bypass rac_config (according to my understand)

then avregister to Avamar Server >>> Client register completed.

but when I browse for on-demand backup I can't browse Database

2015-04-29_145534.png

I also set plugin option as below

2015-04-29_145251.png

I left instance name as blank because of this guide.

2015-04-29_145505.png

unfortunately I still can't browse for database ,any advice ?

PS. I also attached avagent.log

Thank you in advance.

0 Kudos
8 Replies
arturo3
1 Nickel

Re: Can't browse Oracle Database from Avamar GUI

Please get avoracle browse command output, oratab file and tnsnames.ora file:

./avoracle --browse

0 Kudos
Watcharin
1 Copper

Re: Can't browse Oracle Database from Avamar GUI

thanks for your reply

here is the output

bash-3.00$ ./avoracle --browse

ld.so.1: avoracle: fatal: libstdc++.so.6: open failed: No such file or directory

Killed

Thank you.

0 Kudos
arturo3
1 Nickel

Re: Can't browse Oracle Database from Avamar GUI

It seems one library is missing:

ldd avoracle

find / -name  libstdc*

Could you also provide Avamar, Solaris and Oracle versions?

0 Kudos
Watcharin
1 Copper

Re: Can't browse Oracle Database from Avamar GUI

ldd avoracle

        libpthread.so.1 =>       /lib/libpthread.so.1

        libsocket.so.1 =>        /lib/libsocket.so.1

        libnsl.so.1 =>   /lib/libnsl.so.1

        libdl.so.1 =>    /lib/libdl.so.1

        libz.so.1 =>     /usr/lib/libz.so.1

        libsec.so.1 =>   /lib/libsec.so.1

        libproject.so.1 =>       /usr/lib/libproject.so.1

        libstdc++.so.6 =>        (file not found)

        libm.so.2 =>     /lib/libm.so.2

        libgcc_s.so.1 =>         (file not found)

        libc.so.1 =>     /lib/libc.so.1

        libmp.so.2 =>    /lib/libmp.so.2

        libmd.so.1 =>    /lib/libmd.so.1

        libscf.so.1 =>   /lib/libscf.so.1

        libavl.so.1 =>   /lib/libavl.so.1

        libsecdb.so.1 =>         /lib/libsecdb.so.1

        libproc.so.1 =>  /lib/libproc.so.1

        libpool.so.1 =>  /usr/lib/libpool.so.1

        libdoor.so.1 =>  /lib/libdoor.so.1

        libuutil.so.1 =>         /lib/libuutil.so.1

        libgen.so.1 =>   /lib/libgen.so.1

        libcmd.so.1 =>   /lib/libcmd.so.1

        librtld_db.so.1 =>       /lib/librtld_db.so.1

        libelf.so.1 =>   /lib/libelf.so.1

        libctf.so.1 =>   /lib/libctf.so.1

        libxml2.so.2 =>  /usr/lib/libxml2.so.2

        libnvpair.so.1 =>        /lib/libnvpair.so.1

        libexacct.so.1 =>        /usr/lib/libexacct.so.1

        /platform/SUNW,SPARC-Enterprise-T5120/lib/libc_psr.so.1

        /platform/SUNW,SPARC-Enterprise-T5120/lib/libmd_psr.so.1

Solaris Version

SunOS devbla 5.10 Generic_142909-17 sun4v sparc SUNW,SPARC-Enterprise-T5120

                   Oracle Solaris 10 9/10 s10s_u9wos_14a SPARC

     Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.

                            Assembled 11 August 2010

Oracle Version

BANNER

--------------------------------------------------------------------------------

Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production

PL/SQL Release 11.2.0.1.0 - Production

CORE    11.2.0.1.0      Production

TNS for Solaris: Version 11.2.0.1.0 - Production

NLSRTL Version 11.2.0.1.0 - Production

Avamar Version

7.1.0-370

0 Kudos
arturo3
1 Nickel

Re: Can't browse Oracle Database from Avamar GUI

There are a couple of libraries missing:

libstdc++.so.6 =>        (file not found)

libgcc_s.so.1 =>         (file not found)

Could you run the previous find command to search them?

find / -name libstdc++.so.6

find / -name libgcc_s.so.1

0 Kudos
Watcharin
1 Copper

Re: Can't browse Oracle Database from Avamar GUI

find / -name libstdc++.so.6

/usr/sfw/lib/sparcv9/libstdc++.so.6

/usr/sfw/lib/libstdc++.so.6

/opt/AVMRclnt/lib/libstdc++.so.6

/opt/AVMRclnt/lib64/libstdc++.so.6

find / -name libgcc_s.so.1

/usr/lib/AdobeReader/Adobe/Reader8/Reader/sparcsolaris/lib/libgcc_s.so.1

/usr/sfw/lib/sparcv9/libgcc_s.so.1

/usr/sfw/lib/libgcc_s.so.1

/opt/AVMRclnt/lib/libgcc_s.so.1

/opt/AVMRclnt/lib64/libgcc_s.so.1

So it's mean required lib is here but it can't execute right ? sorry to ask this because I'm not familiar with Solaris system.

Please advice.

Thank you again

0 Kudos
Watcharin
1 Copper

Re: Can't browse Oracle Database from Avamar GUI

after I create soft link to file

avoracle start to working but if I run with oracle user I got this

bash-3.00$ ./avoracle --browse

avoracle Info <16787>: vardir = /opt/AVMRclnt/var/clientlogs

avoracle Info <7383>: Browsing started ...

avoracle Error <7273>: Couldn't open /var/opt/oracle/oratab 13

avoracle Info <7958>: browse returning with 0 items

when use root user I got this

root@devbla # ./avoracle --browse

avoracle Info <16787>: vardir = /opt/AVMRclnt/var/clientlogs

avoracle Info <7383>: Browsing started ...

avoracle Info <7958>: browse returning with 0 items

open oratab file I got this.

root@devbla # cat oratab

#

# This file is used by ORACLE utilities.  It is created by root.sh

# and updated by the Database Configuration Assistant when creating

# a database.

# A colon, ':', is used as the field terminator.  A new line terminates

# the entry.  Lines beginning with a pound sign, '#', are comments.

#

# Entries are of the form:

#   $ORACLE_SID:$ORACLE_HOME:<N|Y>:

#

# The first and second fields are the system identifier and home

# directory of the database respectively.  The third filed indicates

# to the dbstart utility that the database should , "Y", or should not,

# "N", be brought up at system boot time.

#

# Multiple entries with the same $ORACLE_SID are not allowed.

#

#

what's next ?

Thank you.

0 Kudos
Highlighted
arturo3
1 Nickel

Re: Can't browse Oracle Database from Avamar GUI

./avoracle --browse --debug --verbose

But at this point I would suggest you to open a support ticket so we can help you out.

0 Kudos