Highlighted
FredvanDonk1
1 Nickel

Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

New Avamar 7.1 with DataDomain 5.5 install (not upgraded).

Running vSphere 5.5.0 with two proxy's.

Doing Image Level backup with no problem (and restore).

Trying to a do a granular file restore from the image is where it goes wrong.

I go to Backup/Restore/Manage, find the VM, find a date, and find a Backup.

I click on the Backup, and two VMDK's show up in the content Window.

I click on the middle Icon "Browse for Granular Restore".

The Proxy Selection window pop's up. I can leave it on automatic or pick one of the two proxy's that are listed, it does not matter. I click Ok.

Next I "should" be able to pick the files I want to restore. But instead I get the attached error message.

"Browser Backup Status"

"Browser ERROR: Invalid response from the client agent"

"java.io.EOFException"

I rebooted the server that runs Avamar Administrator. I uninstalled and re-installed, both the supported Java version and the Avamar Administrator.

I tried it with a different VM, but nothing made a difference.

Lastly I rebooted both Proxy's but that also did not made a difference.

Any idea?

Thanks,

Fred

0 Kudos
1 Solution

Accepted Solutions
FredvanDonk1
1 Nickel

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

After working on this with multiple very talented EMC Avamar engineers over the last few days, the resolution to this problem ended up being a networking issue. (Thank you Rishi, Vineeth, and Bryce!)

There is a lot of information that brought us to the solution, too much to post here. But if you run into this problem, double and triple check your networking, and if you would like to know what we ended up doing, I would ask you to PM me directly.

Case closed 🙂

6 Replies
FredvanDonk1
1 Nickel

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

After working on this with multiple very talented EMC Avamar engineers over the last few days, the resolution to this problem ended up being a networking issue. (Thank you Rishi, Vineeth, and Bryce!)

There is a lot of information that brought us to the solution, too much to post here. But if you run into this problem, double and triple check your networking, and if you would like to know what we ended up doing, I would ask you to PM me directly.

Case closed 🙂

DustyGordon
6 Indium

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

Hi Fred,

I am having a similar issue, and would love to know what you ended up doing to resolve the issue.  Itried to PM you, but it wouldn't let me.

Thanks

Dusty

0 Kudos
8 Krypton

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

Hi,

Could you please post latest detailed logs here, it will be easy for us to understand the issue.

Regards,

Pawan

0 Kudos
DustyGordon
6 Indium

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

When I am trying to restore a file.  I click on the date, backup, Granular Restore, and select the proxy (or leave it automatic) I get the error in the screen shot attached.  This is the same issue that the OP was having.Restore Error.jpg

That is the only error I see.  If there are other logs where would I find them?

0 Kudos
8 Krypton

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

Hi,

Following Kb article describes similar issue but for Exchange while performing GLR. I would recommend you to contact support team for further investigation and resolution.

https://support.emc.com/kb/172152

Regards,

Pawan

0 Kudos
sjohns1
1 Copper

Re: Can't browse image backup for FLR ("Browse for Granular Restore") - Java.io.EOFException

Jump to solution

I had the same problem, and it was a network issue: more specifically, one of the proxys was not registered in DNS. Make sure all of the proxy nodes are correctly registered in DNS.

0 Kudos