wryokom
1 Nickel

Change timeout on Avamar pre and post script processing

Jump to solution

Is there a way to change the length of time Avamar allows for the pre-execution and post-execution scripts to run?  I have a job running on a Linux server with the Avamar v6.0.101-65 client that backs up an Informix database, but before backing it up, the database has to do a dump.  I tell the database to perform the dump in a pre-execution script.  Often the dump takes less than an hour, so it's usually not a problem, but every so often the dump may take longer.  Unfortunately, Avamar seems to automatically give up on the pre-execution script after exactly one hour.  I need to tell it somehow to not give up.

0 Kudos
1 Solution

Accepted Solutions
sandcruise
1 Nickel

Re: Change timeout on Avamar pre and post script processing

Jump to solution

You can use the flag "--run-at-start-clause=timeout-seconds" to increase the timeout duration for your pre-script execution.

On linux server, create a file /usr/local/avamar/var/avtar.cmd and put this line in the file :

--run-at-start-clause=timeout-seconds=SEC

and specify the script timeout in seconds

For example, --run-at-start-clause=timeout-seconds=7200 will setup the script timeout for 2 hours

8 Replies
sandcruise
1 Nickel

Re: Change timeout on Avamar pre and post script processing

Jump to solution

You can use the flag "--run-at-start-clause=timeout-seconds" to increase the timeout duration for your pre-script execution.

On linux server, create a file /usr/local/avamar/var/avtar.cmd and put this line in the file :

--run-at-start-clause=timeout-seconds=SEC

and specify the script timeout in seconds

For example, --run-at-start-clause=timeout-seconds=7200 will setup the script timeout for 2 hours

ionthegeek
4 Ruthenium

Re: Change timeout on Avamar pre and post script processing

Jump to solution

sandcruise beat me to it but I do have some information to add.

You can also specify this setting directly in the dataset:

  • Edit the dataset (click Tools => Manage Datasets..., select the dataset to edit and click the Edit button)
  • Select the Options tab
  • Choose the appropriate plug-in from the drop-down list
  • Click the More button
  • In the "Enter Attribute" field, type run-at-start-clauses
  • In the "Enter Attribute Value" field, type timeout-seconds=7200
  • Click the + button to add the attribute
  • Click OK to save the dataset, then click OK again to dismiss the dataset management window

Edit: Fixed a typo

wryokom
1 Nickel

Re: Change timeout on Avamar pre and post script processing

Jump to solution

Thank you both, sandcruise and ianderson, very much!  I especially appreciate the prompt reply.  This is exactly what I needed, and will save me a lot of headaches.

ottobahn
1 Copper

Re: Change timeout on Avamar pre and post script processing

Jump to solution

Does the attribute need [avtar] at the beginning?

0 Kudos
123kateb
1 Nickel

Re: Change timeout on Avamar pre and post script processing

Jump to solution

Ian Anderson When you make this change and click + button, is it supposed

to be listed under the Options variables on the far right of the screen for the specific dataset?

We are having the same timeout issue and I did the above fix twice to see where its registering this,

but still don't see it under Options - odd?

Also - does it ever revert back to the default option or does it keep your changes forever?

7.5.1-101

0 Kudos
123kateb
1 Nickel

Re: Change timeout on Avamar pre and post script processing

Jump to solution

It appears to only save and use that setting for the next backup, then reverts back to the hour wait?  Ian Anderson 

Going to try making the server edit.

0 Kudos
ionthegeek
4 Ruthenium

Re: Change timeout on Avamar pre and post script processing

Jump to solution

I have never seen a dataset value revert after one backup (except the "overtime" setting where there is an explicit option to permit overtime until successful backup).

0 Kudos
Highlighted
123kateb
1 Nickel

Re: Change timeout on Avamar pre and post script processing

Jump to solution

I have had to make the dataset value edit 3 times now for 2 different db backups that work after I make the change, don't the next weekly backup.  I never change it back, just change it to extend the timeout-seconds time.

Anyone else experience this?  Ian Anderson can you ask QA to test this?  Also it would be nice if the modified attribute displayed under Options when you do change it, otherwise not sure how you verify in the gui that you have made the modification?

0 Kudos