MSM & Avamar 7.4

Just got 2 Avamar grids upgraded to 7.4.1-58. No DataDomain. Just storage nodes.

Was told BMR going away. Installed MSM (Multiple Systems Management) as advised.

Management section appears to work.

Monitoring does not.

Both grids give the following error when I select "Activate Monitoring", and the task is called "Start messaging service":

Error: gridname.domain.com: Unable to activate messaging service: MCSDK10.MethodFault From DataProtectionSystem{id=null}: {FaultMessage: Failed - ERROR: System misconfiguration. /etc/apache2/vhosts.d/vhost-ssl.conf not found.

}

I took a look at both grids and the file "vhost-ssl.conf" is indeed not there.


However, this file is: vhost-ssl.conf.disabled_for_nss

Looking at the modified date and time, they both match up to when the server was upgraded.

It would seem the upgrade changed that file and now MSM can't find it.


Scoured release notes, forums and searched the web. Nothing found.

Anyone have any experience with this? MSM seems pretty cool if I can get it to work.

Thanks!

Tags (2)
0 Kudos
11 Replies
FabianKessler
1 Nickel

Re: MSM & Avamar 7.4

MSM is to buggy at the moment.

Without hotfixes for mcs, there is no correct functionality.

And the hotfixes are also not very good. My hotfix was on hold one week after installation because they found new problems.

Von meinem Samsung Galaxy Smartphone gesendet.

0 Kudos

Re: MSM & Avamar 7.4

Well ok then.

Thanks for the info. 😃

0 Kudos
ionthegeek
4 Beryllium

Re: MSM & Avamar 7.4

Which hotfix did you have issues with please?

0 Kudos
FabianKessler
1 Nickel

Re: MSM & Avamar 7.4

It's the MCS Hotfix Nr. HF279818.

Hotfix-mc-741-58-cumulative-201704

I don't know what the problem is, but the hotfix request was rejected for my second grid after upgrade to 7.4.1.

Emc technician told me, it's on hold.

My first grid has GUI update errors in activity log since the hotfix installation.

I have opened a SR for this.

Von meinem Samsung Galaxy Smartphone gesendet.

0 Kudos
Highlighted
Druehl1
2 Iron

Re: MSM & Avamar 7.4

Hello,

are there any news about this hotfix or perhaps newer hotfixes?

I have to do an MSM installation at a customer with 100 single nodes and 2 Grid systems. As BRM don´t work here since 3 years we hoped that MSM can do the monitoring better.

The customer has just update the Avamar systems to version 7.4.1., and I hope I don´t have to install a hotfix on all 100 single nodes...

0 Kudos
DanaJeff
1 Copper

Re: MSM & Avamar 7.4

Oh, ye of little faith ! Come on, of course you will. and then as soon as you complete those 100 HF installs you will receive either an emergency security patch email or the next GA to v7.5.

We have given up doing any work other than HF and patches, and we only have three dozen Avamar nodes globally.

0 Kudos
pcbureau
1 Copper

Re: MSM & Avamar 7.4

I had the same problem and it is solved now...

Issue is about dual authentication deployed with Avamar 7.4

You can deactivate it with these commands :

enable_secure_config.sh --undo --secure-session

enable_secure_config.sh --undo --secure-ticket

enable_secure_config.sh --undo --dualauth

dpnctl stop mcs

dpnctl start mcs

dpnctl start sched


After that, it's working on MSM.


Regards.

0 Kudos
ionthegeek
4 Beryllium

Re: MSM & Avamar 7.4

The recommended way to change the sessions security mode is to use the corresponding AVP package. Also, the commands that you ran will disable not only dual authentication but also the secure session features. This leaves your system vulnerable to published CVEs.

Most customers will likely want "Authenticated/Single" (if they do not have any 7.1 or older clients) or "Mixed/Single" (if they have 7.1 or older clients which do not support secure sessions).

0 Kudos
pcbureau
1 Copper

Re: MSM & Avamar 7.4

Ok thank you. I had these commands from a EMC presale. I will look for avp package. Where I can find them ?

0 Kudos