Druehl1
2 Iron

Replication between AV5.0 and 6.1.1.

Hello,

are there any problems between the replication of an Avamar Server Version 5.0.3-29 and Version  6.1.1-87.


The supportmatrix says that this is ok, but when I want to add the new system in the EM dashboard I get the error "

Unable to add System. Unexpected error. Please review the tomcat log files".

Vice versa I get the error message

"Added System but error occurred. Network error."

I can do a ping between the systems.

The only thing I see is that the ports which I have to set at the "ADD SYSTEM" are 7778 on the old system and 9443 on the new system. But it don´t help to change this ports.

Any idea?

0 Kudos
7 Replies
ionthegeek
4 Beryllium

Re: Replication between AV5.0 and 6.1.1.

An older system can be added to a newer Enterprise Manager but not vice-versa.

To add an Avamar 5 system to the Avamar 6 EM, the MCS Web Service SDK needs to be installed on the 5.0 grid. The SDK is available as a hotfix but the 5.0 version can only be installed on top of 5.0.4-30 so this system will have to be upgraded. If the hardware supports 6.0 or 6.1, it might be better to upgrade to one of those releases since they both include the SDK "out of the box". In any case, the hotfix number for 5.0 systems is 26176.

Druehl1
2 Iron

Re: Replication between AV5.0 and 6.1.1.

Hi,

thanks for your answer.

But now I have a problem. The customer has 2 Single Nodes with each version 5.0.3.

The plan is to upgrade them, but both of the nodes are at 95% capacity so EMC gave the customer another single node for a quick migration of some files and deleting them on th original nodes so they can be upgraded.

Now as you write this is not possible, do you have any idea how to go on?

Can I do the replication or the setup with mccli?

0 Kudos
ionthegeek
4 Beryllium

Re: Replication between AV5.0 and 6.1.1.

Configuring replication doesn't require the Enterprise Manager. Replication can be configured manually by editing the following file:

/usr/local/avamar/etc/repl_cron.cfg

If you need assistance setting up replication manually, I'd recommend opening a support case.

Druehl1
2 Iron

Re: Replication between AV5.0 and 6.1.1.

Hi,

thanks, the replication is running now.

I have done this with the repl_cron.cfg file.

Druehl1
2 Iron

Re: Replication between AV5.0 and 6.1.1.

Hello ianderson,

one question.

Is it possible to do replication from one single node to 2 different single nodes at the same time?

I am not sure if I can set 2 dest-addr in the repl_cron.cfg file.

In the EM and the MC I only can do a replication between 1 source and 1 destination.

0 Kudos
Highlighted
Pratique2511
2 Bronze

Re: Replication between AV5.0 and 6.1.1.

Well you can replicate to two different avamar servers. Below is the procedure-

You will have to build another file say repl_cron_2.cfg and update the dstaddr flag.

Additionally, goto /usr/local/avamar/bin. Copy repl_cron into a new file repl_cron_2 and replace all the occurrences of repl_cron with repl_cron_2.

Next in the same location you will find a file called dpncron.pm.

Search for the string repl_cron and you will find something like this:

'repl_cron' => [ 'repl_cron' ],

Simply create a line below it with -

'repl_cron_2' => [ 'repl_cron_2' ],    (name of this cron file should be the same as the one created above)

Finally, schedule the replication job in dpn's crontab with the new repl_cron_2.

That should do it !

ionthegeek
4 Beryllium

Re: Replication between AV5.0 and 6.1.1.

Running replication with one source and two destinations would have to be done by setting up two separate replication jobs. I would recommend working with support the first time you set up multiple replication jobs since it involves modifying Avamar software files.

Support for multiple replications is much improved in Avamar 7 and won't require digging around in scripts or manually modifying configuration files.

0 Kudos