Highlighted
nortonex
1 Copper

Restoring Mailbox Exchange 2013 Failed GLR Error

Hello,

I am trying to restore user mailbox from avamar backup (stored on DataDomain). When I choose database it starts retriving contents of backup in this DB. After while I recive error:" Failed to mount database. Please check echange glr logs for more details".

I have check that there is no old files in \program files\avs\var\avfscache, I have restarted AvamarExchangeGLR, I checked that there is no RDB DB mounted (using Get-Mailboxdatabase).

What else I can check?

Thanks for help!

Best regards, Michal.

Below avexglr_plugin.log;

--------------------------------------------------------------------------------------------------------

-----  START avexchglr log 2017-01-26 08:08:53 Central European Standard Time  [7.1.101-145 Windows Server 2012 R2 Datacenter Server Edition (No Service Pack) 64-bit-AMD64]

--------------------------------------------------------------------------------------------------------

2017-01-26 08:08:53 avexchglr Info <7075>: argc = 8

2017-01-26 08:08:53 avexchglr Info <7076>: argv[0]=avexchglr

2017-01-26 08:08:53 avexchglr Info <7076>: argv[1]=--sysdir=C:\Program Files\avs\etc

2017-01-26 08:08:53 avexchglr Info <7076>: argv[2]=--bindir=C:\Program Files\avs\bin

2017-01-26 08:08:53 avexchglr Info <7076>: argv[3]=--vardir=C:\Program Files\avs\var

2017-01-26 08:08:53 avexchglr Info <7076>: argv[4]=--ctlcallport=6040

2017-01-26 08:08:53 avexchglr Info <7076>: argv[5]=--ctlinterface=3027-Browse

2017-01-26 08:08:53 avexchglr Info <7076>: argv[6]=--logtimeformat=default

2017-01-26 08:08:53 avexchglr Info <7076>: argv[7]=--logtimezone=default

2017-01-26 08:08:53 avexchglr Info <6673>: CTL listening on port 16368

2017-01-26 08:08:53 avexchglr Info <10684>: Setting ctl message version to 3 (from 1)

2017-01-26 08:08:53 avexchglr Info <16136>: Setting ctl max message size to 268435456

2017-01-26 08:08:53 avexchglr Info <18208>: Initializing GLR PowerShell interface

2017-01-26 08:08:53 avexchglr Info <13313>: Server name = SVR-EXMB01

2017-01-26 08:09:24 avexchglr Info <15423>: db name = DB1

2017-01-26 08:09:24 avexchglr Info <15423>: db name = DB2

2017-01-26 08:09:24 avexchglr Info <15423>: db name = DB3

2017-01-26 08:09:24 avexchglr Info <15423>: db name = DB4

2017-01-26 08:09:24 avexchglr Info <15423>: db name = DB5

2017-01-26 08:09:24 avexchglr Info <15423>: db name = DB6

2017-01-26 08:10:44 avexchglr Info <18208>: Initializing GLR PowerShell interface

2017-01-26 08:10:55 avexchglr Info <15423>: db name = DB1

2017-01-26 08:10:55 avexchglr Info <15423>: db name = DB2

2017-01-26 08:10:55 avexchglr Info <15423>: db name = DB3

2017-01-26 08:10:55 avexchglr Info <15423>: db name = DB4

2017-01-26 08:10:55 avexchglr Info <15423>: db name = DB5

2017-01-26 08:10:55 avexchglr Info <15423>: db name = DB6

2017-01-26 08:14:30 avexchglr Warning <6788>: Found unknown section 'path-data' in workorder, ignoring

2017-01-26 08:14:30 avexchglr Info <7726>: LISTENING ON PORT 16368

2017-01-26 08:14:30 avexchglr Info <7744>: bindir:

2017-01-26 08:14:30 avexchglr Info <13044>: ctl_spawn successful

2017-01-26 08:14:30 avexchglr Info <7729>: original key [3027-Browse], clone [3027-Browse#1]

2017-01-26 08:14:30 avexchglr Info <6686>: Process 16412 (C:\Program Files\avs\bin\avtar) for workorder Browse#1 started

2017-01-26 08:14:30 avexchglr Info <7732>: Waiting for avtar to finish

2017-01-26 08:14:31 avexchglr Info <10684>: Setting ctl message version to 3 (from 1)

2017-01-26 08:14:31 avexchglr Info <16136>: Setting ctl max message size to 268435456

2017-01-26 08:14:36 avexchglr Info <6688>: Process 16412 (C:\Program Files\avs\bin\avtar) finished (code 0: success)

2017-01-26 08:14:36 avexchglr Warning <15188>: failed to process message type 32 ctl_man_exit

2017-01-26 08:14:36 avexchglr Info <13046>: Manager finished

2017-01-26 08:14:36 avexchglr Error <6677>: Error processing CTL message "<ctl_man_exit key="3027-Browse#1" mid="20700/19688/33" last_ctl_man_key="3027-Browse#1" />

"

2017-01-26 08:14:36 avexchglr Info <19008>: Obtaining available VSS providers

2017-01-26 08:14:36 avexchglr Info <8871>: Gathering writer metadata...

2017-01-26 08:14:38 avexchglr Info <19007>: Adding writer Microsoft Exchange Writer  GUID: {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}  Instance: {9b0b2df2-0260-4a7d-9f46-4f99cca80618}

2017-01-26 08:14:38 avexchglr Info <18208>: Initializing GLR PowerShell interface

2017-01-26 08:14:39 avexchglr Info <13296>: Creating database [DB1_rdb] on server [SVR-EXMB01]...

2017-01-26 08:14:39 avexchglr Error <0000>: Error The specified log folder path ('C:\Program Files\avs\var\avfscache\AVFSMOUNT\exch1\logs') is already in use by another database on the server. Please specify a different log folder path.

Parameter name: LogFolderPath

2017-01-26 08:14:39 avexchglr Error <13268>: Creating database [DB1_rdb] failed!

2017-01-26 08:14:39 avexchglr Error <13355>: Unable to create a database [DB1_rdb]

2017-01-26 08:14:39 avexchglr Error <13346>: Unable to create a restore database

2017-01-26 08:14:39 avexchglr Error <13350>: Exchange GLR mount and restore operations unable to complete.

2017-01-26 08:15:00 avexchglr Error <13522>: Failed to mount database

2017-01-26 08:18:14 avexchglr Info <18208>: Initializing GLR PowerShell interface

2017-01-26 08:18:33 avexchglr Info <15423>: db name = DB1

2017-01-26 08:18:33 avexchglr Info <15423>: db name = DB2

2017-01-26 08:18:33 avexchglr Info <15423>: db name = DB3

2017-01-26 08:18:33 avexchglr Info <15423>: db name = DB4

2017-01-26 08:18:33 avexchglr Info <15423>: db name = DB5

2017-01-26 08:18:33 avexchglr Info <15423>: db name = DB6

2017-01-26 08:21:46 avexchglr Warning <6788>: Found unknown section 'path-data' in workorder, ignoring

2017-01-26 08:21:46 avexchglr Info <7726>: LISTENING ON PORT 16368

2017-01-26 08:21:46 avexchglr Info <7744>: bindir:

2017-01-26 08:21:46 avexchglr Info <13044>: ctl_spawn successful

2017-01-26 08:21:46 avexchglr Info <7729>: original key [3027-Browse], clone [3027-Browse#1]

2017-01-26 08:21:46 avexchglr Info <6686>: Process 2040 (C:\Program Files\avs\bin\avtar) for workorder Browse#1 started

2017-01-26 08:21:46 avexchglr Info <7732>: Waiting for avtar to finish

2017-01-26 08:21:47 avexchglr Info <10684>: Setting ctl message version to 3 (from 1)

2017-01-26 08:21:47 avexchglr Info <16136>: Setting ctl max message size to 268435456

2017-01-26 08:21:52 avexchglr Info <6688>: Process 2040 (C:\Program Files\avs\bin\avtar) finished (code 0: success)

2017-01-26 08:21:52 avexchglr Warning <15188>: failed to process message type 32 ctl_man_exit

2017-01-26 08:21:52 avexchglr Info <13046>: Manager finished

2017-01-26 08:21:52 avexchglr Error <6677>: Error processing CTL message "<ctl_man_exit key="3027-Browse#1" mid="20700/1108/33" last_ctl_man_key="3027-Browse#1" />

"

2017-01-26 08:21:52 avexchglr Info <19008>: Obtaining available VSS providers

2017-01-26 08:21:53 avexchglr Info <8871>: Gathering writer metadata...

2017-01-26 08:21:55 avexchglr Info <19007>: Adding writer Microsoft Exchange Writer  GUID: {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}  Instance: {9b0b2df2-0260-4a7d-9f46-4f99cca80618}

2017-01-26 08:21:55 avexchglr Info <18208>: Initializing GLR PowerShell interface

2017-01-26 08:21:56 avexchglr Info <13296>: Creating database [DB1_rdb] on server [SVR-EXMB01]...

2017-01-26 08:21:56 avexchglr Error <0000>: Error The specified log folder path ('C:\Program Files\avs\var\avfscache\AVFSMOUNT\exch1\logs') is already in use by another database on the server. Please specify a different log folder path.

Parameter name: LogFolderPath

2017-01-26 08:21:56 avexchglr Error <13268>: Creating database [DB1_rdb] failed!

2017-01-26 08:21:56 avexchglr Error <13355>: Unable to create a database [DB1_rdb]

2017-01-26 08:21:56 avexchglr Error <13346>: Unable to create a restore database

2017-01-26 08:21:56 avexchglr Error <13350>: Exchange GLR mount and restore operations unable to complete.

2017-01-26 08:22:25 avexchglr Error <13522>: Failed to mount database

0 Kudos
6 Replies
TARRARE
1 Copper

Re: Restoring Mailbox Exchange 2013 Failed GLR Error

Hi, according to the error on the log, have you checked that you don't have any recovery database already mounted on you ecxhange servers ? If not, try to restart the avamar agent on the server.

0 Kudos
nortonex
1 Copper

Re: Restoring Mailbox Exchange 2013 Failed GLR Error

I checked it and there wasn't mounted recovery database. Restaring avamar agent didn't help.

I was contacting with EMC support and after checking logs I was told that database is to big (500GB). I didn't suppose that 0.5TB database is so big that avamar couldn't restore mailboxes. Now we try to change few flags and increase timeout.

0 Kudos
TARRARE
1 Copper

Re: Restoring Mailbox Exchange 2013 Failed GLR Error

Hi, i'm still on exchange 2010 and avamar 7.2.1 but never had any issues with mounting a recovery database from avamar to make a granular restores ( 4 of my DBs have a size beetween 600 to 700gb).

For me this is not an acceptable response from support, you should ask for escalation

0 Kudos
J_H_
3 Silver

Re: Restoring Mailbox Exchange 2013 Failed GLR Error

I agree that size should not be an issue:  IF  you have that much free space on the server

I am more concerned about the LOG error saying it is already in use by another database.

0 Kudos
TARRARE
1 Copper

Re: Restoring Mailbox Exchange 2013 Failed GLR Error

Hi, there is no need for space on the exchange server as the granular restore is just creating a virtual mount point of the rdb pointing to the exchange data on your grid or datadomain.

0 Kudos
Parizt
1 Copper

Re: Restoring Mailbox Exchange 2013 Failed GLR Error

nothing?

0 Kudos