jsinclair1
2 Bronze

Upgrading Red Hat Client Fails With Missing Dependencies

Jump to solution

I'm trying to upgrade an Avamar client on a RHEL 5.x 64 bit server from 6.1.101-87 to 7.1.101-145 and I'm getting some dependency errors. Here's an example of the output:

[root@server]# rpm -U AvamarClient-linux-sles11-x86_64-7.1.101-145.rpm

error: Failed dependencies:

        libcap.so.2()(64bit) is needed by AvamarClient-7.1.101-145.x86_64

        libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by AvamarClient-7.1.101-145.x86_64

        libxml2.so.2(LIBXML2_2.4.30)(64bit) is needed by AvamarClient-7.1.101-145.x86_64

        libxml2.so.2(LIBXML2_2.6.0)(64bit) is needed by AvamarClient-7.1.101-145.x86_64

        rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by AvamarClient-7.1.101-145.x86_64

I have run "yum update" to make sure everything is updated, but still no luck. I also tried this command with the same error:


yum lcoalinstall AvamarClient-linux-sles11-x86_64-7.1.101-145.rpm

Any help would be greatly appreciated. I have 3 of these servers and all get the same error. They are 5.5, 5.7 and 5.11. Thanks!


0 Kudos
1 Solution

Accepted Solutions
Highlighted
jsinclair1
2 Bronze

Re: Upgrading Red Hat Client Fails With Missing Dependencies

Jump to solution

Ok..so it was late. I just looked at it again and realized I was using the wrong RPM. Oops..ignore this.

0 Kudos
1 Reply
Highlighted
jsinclair1
2 Bronze

Re: Upgrading Red Hat Client Fails With Missing Dependencies

Jump to solution

Ok..so it was late. I just looked at it again and realized I was using the wrong RPM. Oops..ignore this.

0 Kudos