mccli client add command not working

Has anyone had any success getting an mccli client add command to work with a plain old VM client?

I'm using Avamar 7.4.1-58.

the mccli client add command persists in returning a "The Virtual machine could not be located" message regardless of how I have either the --location switch syntax or the --folder syntax. What's it looking for?

I can see the client to be added in the GUI Administration add client pane, and it adds fine from there, but automation is needed, without the GUI mouse clicks. also, in that GUI add client window, I can see the client with a "Location" column under Hosts and Clusters, and I can also see that same client to be added under VM's & Templates with a "Location" column, but with different information.

None of this information seems to work with the mccli client add command. I think I've tried every permutation, but still no success.

Anyone ever got this to work?

Any suggestions would be appreciated.

0 Kudos
2 Replies
1 Copper

Re: mccli client add command not working

I fought with this for awhile and this is what I ended up with. Just tested and it works in my environment (also 7.4.1)

mccli client add --type=vmachine --name=VMNAME --datacenter="DATACENTER" --domain=/VCENTER --folder="/Folder/Path/From/VM-and-Templates"

I ended up going the dynamic rules route.

0 Kudos
3 Argentium

Re: mccli client add command not working

If you know the exact path of the VM (folder path) on the vCenter you could use the following mccli command

mccli client add --type=vmachine --name=vmname --datacenter=datacentername --folder=/foldername/leve1/level2/ --domain=/VcenterName/VirtualMachines/

If you have proxycp.jar then you can run the following command

java -jar proxycp.jar --addvm --vc <vCenter> --vm <vmName as displayed in vCenter>


Amol Powar

0 Kudos