Highlighted
2 Bronze

CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

Hello Community,

i wanna upgrade my flare from 2.16 to 2.19.

But, all i try  .. no success.

  • If iy try the update with Navisphere Service Taskbar, "in the target system runs a version that is not supported, you need minimum 2.19..."(yeah..i try! ).
  • Next try with USM told me "in this system runs version 6.16.4.1.0, which is not compatible with this version of unisphere", after i try to connect to my host. (OK..the storage is really not uptodate..)
  • last but not least, i try navicli:
    • >NaviCLI.exe -h <IP> firmware C:\EMC\repository\Downloads\CX300-Bundle-02.19.300.5.045.pbu

    • Error: firmware command failed
    • Command not Supported

How can i update this beast, where is the solution?

For any hint i´m really really grateful.

dp

PS: some informations,,if more needed, no problem.

I> getagent

Agent Rev:     6.16.2 (0.1)

Name:                K10

Desc:

Node:               

Physical Node:       K10

Signature:           1126477

Peer Signature:      1126453

Revision:            2.16.300.5.018

SCSI Id:             0

Model:               CX300

Model Type:          Rackmount

Prom Rev:            3.20.00

SP Memory:           1024

Serial No:          

SP Identifier:       B

Cabinet:             DPE2

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
5 Rhenium

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

Check the CLI manual for the command NDU - that's the command used to upgrade the flare version.

On Navisphere 16, you need to use an older tool called Software Installation Wizard.

You can also use Navisphere - if you right click the name of the array and select Software Operation/Software Installation Wizard - you should be able to upgrade from there. If that doesn't work, try turning on engineering mode and try again.

glen

View solution in original post

10 Replies
Highlighted
5 Rhenium

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

Check the CLI manual for the command NDU - that's the command used to upgrade the flare version.

On Navisphere 16, you need to use an older tool called Software Installation Wizard.

You can also use Navisphere - if you right click the name of the array and select Software Operation/Software Installation Wizard - you should be able to upgrade from there. If that doesn't work, try turning on engineering mode and try again.

glen

View solution in original post

Highlighted
2 Bronze

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

Hello Glen,

thanks for your hints.

This I had already been tested:

>NaviCLI.exe ndu -h <IP> firmware C:\EMC\repository\Downloads\CX300-Bundle-02.19.300.5.045.pbu

Command not Supported

The ndu command is no longer supported in NaviCLI.  Please refer to the Release Notes for instructions on how to perform a software upgrade.

Software Installation in Navisphere runs in a Error, i have already been try. (wrong file? pbu?)

CX300-Bundle-02.19.300.5.045.pbu is the right file in this case?

i ask beacause, if i try to navigate to my .pbu file, he awaits a .lst or .ena file by default:

"software bundles and eneablers (.lst, ena)"

then i choose "all data types" and select my pbu.

in engineering mode:

he runs in an error:

Query Failed: SP A: This file is either not a valid upgrade file or is corrupt.  It may have been corrupted during a file transfer. Obtain a new copy and retry the upgrade. (0x71518003).

I try to find Software Installation Wizard...

thanks

0 Kudos
Highlighted
3 Silver

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

hello!

i recommend going this way:

1.Generate procedure by Clariion Procedure Generator (not latest version, i successfully generate by version 4.4.6).

2.Update using NST.

Cut from procedure "Does your activity involve upgrading software on a storage system running a version of FLARE that is lower than Release 19?  If yes, use version 6.29.2 NST"

3.Update to the latest release for cx300 if possible, is 02.26.300.5.031 flare version and it available at support.emc.com.

0 Kudos
Highlighted
2 Bronze

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

OK, Software Installation Wizard is the solution, it runs 2.19.

Now upgrade to 2.26.

Thanks Glen.

0 Kudos
Highlighted
2 Bronze

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

Hm, i cant upgrade to 2.26, he told me that i must activate 2.19?

Where i find this activiation prozess?

0 Kudos
Highlighted
4 Tellurium

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

In Navisphere, go to system properties (right click on serial no/name)  > software tab. Check if the current FLARE ( 2.19) is commited or not .If it is not committed, you will find a commit button there.

Highlighted
3 Silver

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

i`m not sure, but i think you must upgrade to r19 at first, and after that to r26.

Use NST vs SIW, SIW a very old tool, NST a newer.

I strongly recommend generate procedure for update, procedure describe some workarounds and issues during ugrade process. If you cant generate procedure, i can help and upload it to anywhere.

0 Kudos
Highlighted
2 Bronze

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

Hello undertaker,

if you can upload this software, it would be very nice.

these file are n.a. im emc downloads.

thank you

0 Kudos
Highlighted
3 Silver

Re: CX300 - Flare Upgrade 2.16.300.5.018 to 02.19.300.5.045

Jump to solution

i checked it`s no upgrade from r16 to r 26 directly, you must upgrade to r19 at first.

i`m sorry i haven`t NST ver.6.26, try SIW 6.19.81.1.10 to upgrade from r16 to r19 and when you upgraded to r19 check your version of NST for upgrading to r26.