StorageAdmin2
3 Argentum

Linux OS - SAN on Clariion - I/O error read failed after 0 of 4096 at 0: Input/output error

Hi,

I got an issue with one of my Linux Host with single HBA zoned to two Clariion ports with CLaropt 1 mode option. 4 Luns on SPA and 5 Luns on SPB.

The issues is that the OS guy has started getting the I/O errors on all the secondary devices but as of now the devices are accessible.

I think this might be a multipathing issue and have asked to check and compare the working one, but wanted some opinion if anyone has had any such experience.

Also do you think ClarOpt mode 3 might work ? But It says any IO to a non-owning SP will be rejected which can be dangerous if there was a trespass .

/dev/sdq: read failed after 0 of 4096 at 0: Input/output error
/dev/sdr: read failed after 0 of 4096 at 0: Input/output error
/dev/sds: read failed after 0 of 4096 at 0: Input/output error
/dev/sdt: read failed after 0 of 4096 at 0: Input/output error
/dev/sdl: read failed after 0 of 4096 at 0: Input/output error
/dev/sdm: read failed after 0 of 4096 at 0: Input/output error
/dev/sdn: read failed after 0 of 4096 at 0: Input/output error
/dev/sdo: read failed after 0 of 4096 at 0: Input/output error
/dev/sdp: read failed after 0 of 4096 at 0: Input/output error


sd 3:0:2:6: Device not ready
sd 3:0:2:6: SCSI error: return code = 0x08000002
Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sdi: Current: sense key: Not Ready
Add. Sense: Logical unit not ready, manual intervention required

Labels (1)
0 Kudos
3 Replies
StorageAdmin2
3 Argentum

Re: Linux OS - SAN on Clariion - I/O error read failed after 0 of 4096 at 0: Input/output error

Never mind, this is solved by editing the multipathing conf file. I think it was not properly configured as per the active/passive controller

# EMC Clariion (active/passive)

  device {

  vendor "DGC "

  product "RAID 5 "

  path_grouping_policy failover

  getuid_callout "/sbin/scsi_id -g -u -s /block/%n"

  path_checker emc_clariion

  path_selector "round-robin 0"

  features "0"

  hardware_handler "1 emc"

  failback immediate

  }

kelleg
5 Rhenium

Re: Linux OS - SAN on Clariion - I/O error read failed after 0 of 4096 at 0: Input/output error

Please mark your question as answered - it may help others with similar issues.

Thanks for updating the fix.

glen

0 Kudos
StorageAdmin2
3 Argentum

Re: Linux OS - SAN on Clariion - I/O error read failed after 0 of 4096 at 0: Input/output error

Well , I have marked the discussed with a helpful answer.

0 Kudos