Highlighted
7 Thorium

Managing AX150 using navicli

Jump to solution

I have an AX150 that i would like to get to using navicli/naviseccli, regardless of what command i issue to SP i get an error message:

NaviCLI.exe -h ax150.mycompany.local getall

Error: getall command failed

Command not Supported

This command is not supported on this subsystem type.

The only reason i can think of this is not working is because this box is running Navisphere Express and needs to be upgraded to full version of Navisphere Manager. Can somebody confirm ?

Thanks

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
4 Ruthenium

Re: Managing AX150 using navicli

Jump to solution

Sorry for the delay.  Lol this is early for me actually as most of the time I'm checking in later in the evening.

Yes, unfortunately without upgrading your array to Naviphere Manager, you won't be able to run navicli commands against the AX150.  It wasn't until the AX4-5 series where a subset of commands was supported with Navisphere Express running.

View solution in original post

0 Kudos
9 Replies
Highlighted
5 Rhenium

Re: Managing AX150 using navicli

Jump to solution

Do any of the other general commands work?

I'm trying to locate an AX150 - it's somewhere in the lab, but can't locate it right now.

glen

Highlighted
7 Thorium

Re: Managing AX150 using navicli

Jump to solution

tried getagent, getlun ..same error message

0 Kudos
Highlighted
4 Beryllium

Re: Managing AX150 using navicli

Jump to solution

May I know the Version of Navisphere Server/CLI Software?

What is the FLARE OS Version?
Can you try to run the commands after installing older version of NaviCLI?

Might I suggest to check: Does the CLARiiON AX100-Series array respond to Navisphere CLI commands?

(Sorry, this is what I could find with no access to Powerlink)

Added KB Article Link and Other Q's for Mr. D

Highlighted
7 Thorium

Re: Managing AX150 using navicli

Jump to solution

FLARE-Operating-Environment: 02.20.150.5.019

tried 7.32 and then 6.28

0 Kudos
Highlighted
4 Ruthenium

Re: Managing AX150 using navicli

Jump to solution

Hey Dynamox,

Yes, your initial assumption is correct.  It wasn't until the AX4-5 series where a subset of commands was supported with Navisphere Express.

1) First verify what version of Navisphere CLI is supported for the AX150 by checking the release notes.

I wouldn't consider anything over Navisphere CLI v29:

http://powerlink.emc.com/km/live1/en_US/Offering_Technical/Technical_Documentation/300-009-722.pdf

release notes.png

It actually stops listing the AX150 in the latest release notes:

"EMC® Unisphere® Host Software/CLI and Utilities for VNX® OE for Block Version 1.2.2.1.0020"

2) Then, hunt down an older version of the the Navisphere CLI command reference:

http://powerlink.emc.com/km/live1/en_US/Offering_Technical/Technical_Documentation/300-003-628_a11.p...

a) Skip to the following section:

About EMC Navisphere CLI AX4-5 series and AX series support

b) You'll see the following passage:

[...]

You must upgrade your storage system to Navisphere Manager

before you can use Navisphere CLI with an AX series (AX150 series

and AX100 series) storage system. Refer to the document for

upgrading a storage system to Navisphere Manager.

[...]

c) Just for reference, here are the comments about AX4-5:

[...]

Note: AX4-5 series storage systems running either Navisphere Express or

Navisphere Manager can be managed with Secure CLI. Some commands are

not available with Express.

[...]

3) Also, when doing any research for your AX150, I would stick with:

a) Powerlink

b) http://www.emc.com/microsites/clariion-support/ax150

Here you'll also see reference to the latest code:

For optimal performance and continued support your array should be running Flare operating system release 02.20.150.5.026


0 Kudos
Highlighted
4 Ruthenium

Re: Managing AX150 using navicli

Jump to solution

Also, while I'm sure you are personally okay with it (well it is your only option if you want to manage it with Navisphere CLI), but it is worth noting for others that once you install the Navisphere Manager enabler, there isn't any way to uninstall it.

0 Kudos
Highlighted
7 Thorium

Re: Managing AX150 using navicli

Jump to solution

thanks Christopher, so to summarize your post: if i don't have Navisphere Manager i can't use navicli (regardless of its version) ?

this array is not under active support contract, i have a feeling this customer will not want to pay for an upgrade/enabler either.

0 Kudos
Highlighted
4 Ruthenium

Re: Managing AX150 using navicli

Jump to solution

Sorry for the delay.  Lol this is early for me actually as most of the time I'm checking in later in the evening.

Yes, unfortunately without upgrading your array to Naviphere Manager, you won't be able to run navicli commands against the AX150.  It wasn't until the AX4-5 series where a subset of commands was supported with Navisphere Express running.

View solution in original post

0 Kudos
Highlighted
7 Thorium

Re: Managing AX150 using navicli

Jump to solution

thank you

0 Kudos