3 Argentum

adding new lun to existing storage group brings up conflicting messages

I recently noticed the following issue when adding a new lun to an existing storage group on our clariion array(s).

This host is already connected to a different storage group.
Connecting it to the current storage group will cause it to be disconnected from the other storage group.
This will cause the host to be unable to access the LUNs that are within the other storage group.

I accept the popup message and another popup appears:
You are adding multiple hosts to this storage group. Each host will be able to write to all LUNs within the storage group.

I accept the second popup and a 3rd appears:
This operation will connect host(s) to the storage group.

I accept the 3rd popup and the activity to add the lun to the storage group completes.

Nothing negative happens but I am concerned with the popup messages as they indicate something happening that was not part of the activity to add a lun to an existing storage group.

I have opened a SR but am curious if anyone else has seen this?

This has occurred on our CX3 and CX4 arrays running flare 3.26.080.5.020 and 4.28.000.5.504

Jim
Labels (1)
0 Kudos
4 Replies
5 Rhenium

Re: adding new lun to existing storage group brings up conflicting messages

In your question:

"I recently noticed the following issue when adding a new lun to an existing storage group on our clariion array(s).

"This host is already connected to a different storage group.
Connecting it to the current storage group will cause it to be disconnected from the other storage group.
This will cause the host to be unable to access the LUNs that are within the other storage group."

Are you adding a new LUN to an existing Storage Group or are you adding a host to an existing Storage group. The message above usually occurs when you add a host to a Storage Group that already contains a host.

glen
0 Kudos
4 Ruthenium

Re: adding new lun to existing storage group brings up conflicting messages

Jim,
In addition to what Glen said, you will see that warning message if the host you are adding to a storage group already belongs to a storage group. A host can only belong to one storage group, but you can assign LUNs to multiple storage groups. You can assign multiple hosts to a single storage group, but that is only supported if there is some form of clustering software that controls LUN access.

From the error messages you received this is what it appears you did:

Added Host A to Storage Group B while Host A was already assigned to Storage Group A. This is why you received the warning about the Host A being disconnected from Storage Group A. Since Host B was already assigned to Storage Group B this is why you received the warning about adding multiple hosts to a storage group.
0 Kudos
2 Bronze

Re: adding new lun to existing storage group brings up conflicting messages

Hi,
I'm having the same "issue" as with Jim. I checked and re-checked if the host I'm adding to a storage group already belong to another storage group, and it is not, but the messages are the same. "This host is already connected to a different storage group."
Do I need to apply any fixes to the storage array to do away with this messages?
Thanks!
0 Kudos
3 Argentum

Re: adding new lun to existing storage group brings up conflicting messages

The problem can be the result of manual registered initiator .
If you have manual register the initiator make sure you put different ipaddress for each set of initiator that belong to the same host .
If you use a dummy ip equal for all the initiators the NaviSphere will get confuse .
Regards
Pierluca
0 Kudos