montyjanu
1 Copper

navicli command hangs but naviseccli is working

Jump to solution

Hi,

This is a linux 5.5 server . I have installed navicli rpm on it . naviseccli is working but navicli commands just hang. One of my application needs navicli to work. Any pointers as to why navicli is not working ?

Labels (2)
Tags (2)
1 Solution

Accepted Solutions
kelleg
4 Ruthenium

Re: navicli command hangs but naviseccli is working

Jump to solution

It would depend on the version of Navisphere CLI installed on the host the version running on the array - they should match. Also, some navicli commands will not longer work and have been replaced by naviseccli commands - in the CLI User Manual there is a section that explains the removal of navicli commands.

Navicli commands stopped being included with release 26. If you install R28 and higher and you do not already have an earlier version installed, you will not have access to "classic" navicli commands. Newer arrays may not response to older navicli commands. The release notes will provide more detailed information about this.

glen

0 Kudos
4 Replies
Highlighted
avs
2 Iron

Re: navicli command hangs but naviseccli is working

Jump to solution

Hello

Do you have firewall between linux host and clariion box?

Clasic CLI uses 6389 TCP port for basic management and Secure CLI uses 443 and 2163.

Alex

montyjanu
1 Copper

Re: navicli command hangs but naviseccli is working

Jump to solution

Thanks, I checked and the firewall rules allow all ports between them.

0 Kudos
kelleg
4 Ruthenium

Re: navicli command hangs but naviseccli is working

Jump to solution

It would depend on the version of Navisphere CLI installed on the host the version running on the array - they should match. Also, some navicli commands will not longer work and have been replaced by naviseccli commands - in the CLI User Manual there is a section that explains the removal of navicli commands.

Navicli commands stopped being included with release 26. If you install R28 and higher and you do not already have an earlier version installed, you will not have access to "classic" navicli commands. Newer arrays may not response to older navicli commands. The release notes will provide more detailed information about this.

glen

0 Kudos
montyjanu
1 Copper

Re: navicli command hangs but naviseccli is working

Jump to solution

Sorry for late reply, but this answer helped me. I started using naviseccli and gave up on using the navicli in my scripts. Thanks all..

0 Kudos