GJCBS
1 Copper

Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

I have built a new server for hosting all our control center applications and the browser will not allow me to connect to the Celerra Manager console. I get an error which simply states "Cookies must be enabled on the browser to login to Celerra Manager."

I have changed the IE settings to accept ALL cookies, and added the certificate to the client and added the site to the Trusted Sites list. I have tried from my desktop with the same results. Tried turning off firewall, but I am running out of ideas. Powerlink listed a note about the host having an _ in the name, but our host does not. UGH!

Anyone had this before?
Tags (2)
0 Kudos
8 Replies
ironman4
1 Nickel

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

I found one more knowledge base solution that addresses this. Hopefully this will help:

ID: emc150161
Domain: EMC1
Solution Class: 3.X Compatibility

Fact Celerra ALL

Fact EMC SW: NAS Code 5.4.x

Fact EMC SW: NAS Code 5.5.x

Symptom Celerra manager will not start.

Symptom Receiving pop-up error stating "Cookies must be enabled on the browser to login to Celerra Manager."

Symptom Unable to log into Celerra Manager.

Fix When opening up Celerra Manager, make sure use the prefix http://celerra01 rather than secure https://celerra01. For testing purposes, also turn off any firewall applications running on the client system.

Note Cookies must be enabled on the browser to login to Celerra Manager.

Note Supported versions of Web Browser and Java are being used.

Note Cookies are enabled.
0 Kudos
GJCBS
1 Copper

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manage

Thanks ironman. I had to create a host entry on the PC/server for the Celerra and use the name, then it worked. Very odd, but glad it is working.
0 Kudos
GJCBS
1 Copper

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

See follow-up note. Following the suggestion and adding a host entry on the affected machines, I am now able to login.
0 Kudos
IanSchorr
2 Iron

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manage

This generally happens if the IE security policy doesn't allow cookies to be saved for a particular host.

One reason we've run into is when the hostname you're connecting to contains an underscore character (i.e. "Celerra_1"). Microsoft considers this name to be invalid (technically, it's an invalid DNS/host name) and IE 6 (or 5.5 starting with security patch MS01-055) will not store cookies for sites with these kinds of names.

The problem above happens even if the name is in the local hosts file (instead of just DNS), so I don't believe what you're seeing is the same problem. It's probably the same general cause, though - Internet Explorer has decided not to store cookies.

One reason might be your IE security settings. If, for example, it thinks that the Celerra is in the "Internet" zone and your policy doesn't allow hosts in that zone to set cookies, but DOES allow them if the host is in the "Local intranet" zone (which it might now by setting a local host entry) - then you'll have this problem.
0 Kudos
Rainer_EMC
5 Rhenium

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

using http://<IP_Adress> normally also works
0 Kudos
JohnH4
1 Nickel

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

FYI - I had same problem with "Cookies must be enabled ..."

FIX: Try an FQDN for the host

i.e.

instead of https://celerra01

use https://celerra01.domain.com

Seems to be an addr resolution issue. -John
0 Kudos
Roscoe95
1 Copper

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

We had a simular problem using https://10.36.127.15/Login (which failed) Worked when we used https://10.36.127.15/
0 Kudos
kirkr1
1 Copper

Re: Cookies Must Be Enabled Error in IE trying to connect to Celerra Manager

I experienced this same behavior. Unfortunately I was unable to use http: in my environment. I drilled down into IE options:

Tools--> Internet Options--> Advanced.

Scroll down to Security:
Allow active content to run in files on My Computer.

I'm like 90% sure this corrected my issue, but I also clicked two other items that didn't seem relevant
0 Kudos