Highlighted
kjstech
3 Argentium

filesystem deletion not allowed because it has checkpoints

Jump to solution

Hello all,

I am trying to delete a filesystem that I migrated everything off of.  I want to repurpose it's space and step one is to blow it away.  It used to replicate to our DR site but I stopped replication and then deleted it from both the source and destination.

So when I go to delete this filesystem I get an error message Delete file system vm1-sata. Operation is not allowed because file system has checkpoints.

Severity: Error Error
Brief Description: Operation is not allowed because file system has checkpoints.
Full Description: No additional information is available.
Recommended Action: No recommended action is available. For more information and assistance: 1. Log into http://powerlink.emc.com and go to Support > Search Support. 2. Use the message ID or text from the error message's brief description to search.
Message ID: 13691191307

However if I putty in and run rs_ckpt vm1-sata -list ALL it doesnt show any checkpoints for me to try a nas_fs -delete ckpt_name.

So how can I delete this filesystem?  I don't need it anymore.  Is my syntax incorrect?


# fs_ckpt vm1-sata -list ALL

id    ckpt_name                creation_time           inuse fullmark   total_savvol_used  ckpt_usage_on_savvol

Info 26306752329: The value of ckpt_usage_on_savvol for read-only checkpoints may not be consistent with the total_savvol_used.

id    wckpt_name               inuse fullmark total_savvol_used  base  ckpt_usage_on_savvol


1 Solution

Accepted Solutions
kjstech
3 Argentium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

Ok chat fixed it!

So replicaiton was deleted both source and destination, but for some reason the root chkpt's were not removed. 

Learned from chat-

First you check the info for the specific file system nas_fs -i vm1-sata

in the ckpts it shows root_rep_ckpt_38_37335_1,root_rep_ckpt_38_37335_2

Then the command to delete them

/nas/sbin/rootnas_fs -d root_rep_ckpt_38_37335_1 -o umount=yes -ALLOW_REP_INT_CKPT_OP

/nas/sbin/rootnas_fs -d root_rep_ckpt_38_37335_2 -o umount=yes -ALLOW_REP_INT_CKPT_OP

Then look at the file system info again and under ckpts there are none.

Now the filesystem can be deleted!

10 Replies
Rainer_EMC
5 Osmium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

Probably some internal checkpoints from the replication left over

Search the forum – I think we had that case recently

0 Kudos
dynamox
6 Thallium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

fs_ckpt <fsname> -list -all

use

/nas/sbin/rootnas_fs -delete  <checkpoint name>

kjstech
3 Argentium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

Thanks dynamox.  My syntax was wrong, I forgot the dash before the word all.

$ fs_ckpt vm1-sata -list -all

id    ckpt_name                creation_time           inuse fullmark   total_savvol_used  ckpt_usage_on_savvol

56    root_rep_ckpt_38_37335_1 05/27/2011-07:59:27-EDT   y   90%        58%                58%

57    root_rep_ckpt_38_37335_2 05/27/2011-07:59:32-EDT   y   90%        58%                0%

Info 26306752329: The value of ckpt_usage_on_savvol for read-only checkpoints may not be consistent with the total_savvol_used.

$ /nas/sbin/rootnas_fs -delete root_rep_ckpt_38_37335_1

Error 3101: root_rep_ckpt_38_37335_1 : filesystem is mounted, can not delete  ro_servers=server_2

$ /nas/sbin/rootnas_fs -delete root_rep_ckpt_38_37335_2

Error 3101: root_rep_ckpt_38_37335_2 : filesystem is mounted, can not delete  ro_servers=server_2

Now my question is, how do I resolve the filesystem is mounted error?

0 Kudos
kjstech
3 Argentium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

Ok I found it under mounts in unisphere.  Deleted it and also su to root just in case you need root and now I get this:

# /nas/sbin/rootnas_fs -delete root_rep_ckpt_38_37335_1

Error 2225: replication internal checkpoint : invalid operation

# /nas/sbin/rootnas_fs -delete root_rep_ckpt_38_37335_2

Error 2225: replication internal checkpoint : invalid operation

0 Kudos
dynamox
6 Thallium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

try

/nas/sbin/rootnas_fs -delete root_rep_ckpt_38_37335_2 -o umount=yes

0 Kudos
kjstech
3 Argentium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

$ /nas/sbin/rootnas_fs -delete root_rep_ckpt_38_37335_2 -o umount=yes

Error 2225: replication internal checkpoint : invalid operation

Nope, didn't work.  Do I need to open up a support case on this?  Hate to have to wait awhile to get this done 😞

If the GUI in Unisphere simply gave me the option to override the warning and automatically delete the checkpoints we wouldn't even be in this situation. Instead of a hard error it should be "Filesystem has checkpoints.  Would you like to continue deletion?  Deletion will also remove the checkpoints".  A simple Yes or Cancel would have been appropriate.  How do I get that suggestion passed onto developers?

0 Kudos
dynamox
6 Thallium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

open a chat session, that will be faster

0 Kudos
Rainer_EMC
5 Osmium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

Yes – use support chat

They will most likely provide you with an support only switch to force deletion

0 Kudos
kjstech
3 Argentium

Re: filesystem deletion not allowed because it has checkpoints

Jump to solution

Ok chat fixed it!

So replicaiton was deleted both source and destination, but for some reason the root chkpt's were not removed. 

Learned from chat-

First you check the info for the specific file system nas_fs -i vm1-sata

in the ckpts it shows root_rep_ckpt_38_37335_1,root_rep_ckpt_38_37335_2

Then the command to delete them

/nas/sbin/rootnas_fs -d root_rep_ckpt_38_37335_1 -o umount=yes -ALLOW_REP_INT_CKPT_OP

/nas/sbin/rootnas_fs -d root_rep_ckpt_38_37335_2 -o umount=yes -ALLOW_REP_INT_CKPT_OP

Then look at the file system info again and under ckpts there are none.

Now the filesystem can be deleted!