Highlighted
JPearson2
1 Copper

Cannot connect using user=,secret= URL

Jump to solution

I am trying to connect to a Centera cluster from Java using a url like this:

centera.domain.com?user=appuser,secret=p4ssw0rd

But I get this error message:

com.filepool.fplibrary.FPLibraryException: Failed to authenticate PEA data

        at com.filepool.fplibrary.FPPool.<init>(Unknown Source)

        ...

I am able to connect using a PEA file, but because PEA files are not encrypted, we are not allowed to use them in production. The video at this URL

https://community.emc.com/docs/DOC-3162

indicates that you can use a user=,secret= URL to connect instead of using a PEA file (at about 25 minutes in, section "Centera Access Profiles").

Is this a problem with the URL, or does some flag need to be set on the account in Centera to allow a connection like this?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
JPearson2
1 Copper

Re: Cannot connect using user=,secret= URL

Jump to solution

It turns out that the video was incorrect. It says the URL is "address?user=username,secret=password" but the URL is actually "address?name=username,secret=password".

See https://community.emc.com/docs/DOC-1038 under the "Application Profile Definitions" section for the correct format.

0 Kudos
4 Replies
mfh2
3 Argentium

Re: Cannot connect using user=,secret= URL

Jump to solution

Hello J -

Is there a Centera replica in the environment? If so, and you are using default connection settings, the user/secret you are passing in must work with both the primary and the replica for the connection authentication to succeed.

You could try setting this environment variable which will tell the SDK not to authenticate against the replica unless it needs to do an actual failover:

    set FP_OPTION_OPENSTRATEGY=1

Hope you enjoyed the video!

Best Regards,

Mike Horgan

0 Kudos
JPearson2
1 Copper

Re: Cannot connect using user=,secret= URL

Jump to solution

As far as I know, there is no replica. I am only providing a single Centera address. I've asked the team in charge of the Centera whether there is a replica.

I tried setting that environment variable, but it did not help. I am still getting the same error message during the initial FPPool connection.

The video was very helpful, and served as the basic outline for the first pass as this application.

0 Kudos
mfh2
3 Argentium

Re: Cannot connect using user=,secret= URL

Jump to solution

This 'style' of connection string definitely does work, and is quite popular in the field.  Are you sure you are passing the correct password?  You might try creating a new profile with a known password (use 'prompt' when it is time to choose the password style while creating the profile) just as a test.

If you are still stumped, an SDK log of the connection attempt would be helpful. Set this variable:

    FP_LOGPATH=C:\Temp\MySDKApp.log

and you will see a file created in the chosen location when you start your program.  You can post it here and I will have a look.

Best Regards,

Mike Horgan

0 Kudos
JPearson2
1 Copper

Re: Cannot connect using user=,secret= URL

Jump to solution

It turns out that the video was incorrect. It says the URL is "address?user=username,secret=password" but the URL is actually "address?name=username,secret=password".

See https://community.emc.com/docs/DOC-1038 under the "Application Profile Definitions" section for the correct format.

0 Kudos