himanshu_karki
1 Copper

Unable to connect to Online Public Cluster

Hi,

I was trying to create an Pool from an Online Public cluster from the ip addresses and .pea  files metioned at URL- https://community.emc.com/docs/DOC-1038

I tried the following combinations to open a Pool -

(i) "128.221.200.60?c:\\us2_profile3_rdqeDcw.pea" or, "128.221.200.60" to connect to US2 (after copying file 'us2_profile3_rdqeDcw.pea' to my local drive)

(ii) "128.221.200.56?c:\\emea1armtesting.pea" or, "128.221.200.56" to connect to EMEA 1 (after copying file 'emea1armtesting.pea' to my local drive)

I am using .NET wrapper to connect.

Gets the Error string = 'FP_NO_POOL_ERR' with message - "no primary cluster found".

Can anybody let me know that am i on right track and if yes, any other working location for the Online Public cluster to be able to connect to.

Thanks,

Himanshu

0 Kudos
7 Replies
gstuartemc
2 Iron

Re: Unable to connect to Online Public Cluster

Both of those clusters are currently connectable. Have you ensured that port 3218 is open for UDP and TCP in both directions?

0 Kudos
himanshu_karki
1 Copper

Re: Unable to connect to Online Public Cluster

No i didn't did that before.

Well, I tried now by ADDing the exception for the said port no. i.e. 3218 for UDP and TCP to Firewall which didn't worked. Next i putted Wirewall to OFF and tried again. In both scenarios it gave the same error message - "no primary cluster found".

Yet to figure out where the root cause is.

HIMANSHU

0 Kudos
gstuartemc
2 Iron

Re: Unable to connect to Online Public Cluster

It's not a local firewall that I am concerned about, it is the one which your IT department will have deployed. You need to ask your Network Administrator to open that port externally to the Internet on your company firewall.

0 Kudos
NRushefsky
1 Copper

Re: Unable to connect to Online Public Cluster

I am having the same issue.

I am using the GetClusterInfo.cs example with the .NET wrapper.

my connection string is : static String clusterAddress = "128.221.200.184?C:\\Users\\nrushefsky.VISTASG\\Documents\\PEAFiles\\emea3profile1_rdqeDcw.pea";

and when I run the line

FPPool.RegisterApplication("GetClusterInfo", "3.1");

using (FPPool myPool = new FPPool(clusterAddress))
{

}

I get the following erros:

error -10020

"no primary cluster found"

"ClusterCloud::getPrimaryCluster(0)<FPPool::Open(128.221.200.184?C:\Users\nrushefsky.VISTASG\Documents\PEAFiles\emea3profile1_rdqeDcw.pea)<_FPPool_Open(128.221.200.184?C:\Users\nrushefsky.VISTASG\Documents\PEAFiles\emea3profile1_rdqeDcw.pea)<FPPool_Open8(128.221.200.184?C:\Users\nrushefsky.VISTASG\Documents\PEAFiles\emea3profile1_rdqeDcw.pea)"

I have had my network administrator open up the port 3218 for both TCP and UDP.  I have also done the same on my local windows firewall just to make sure that the network traffic can get threw.  But I have had no luck with this connection.

On the other hand.  When I change my connection string to be : "128.221.200.60?C:\\Users\\nrushefsky.VISTASG\\Documents\\PEAFiles\\us2_profile1_rqecw.pea" it seems to connect just fine.

Is there a probem with EMEA 3 that is preventing me from connecting or have I done something wrong?

0 Kudos

Re: Unable to connect to Online Public Cluster

the cluster is likely dead.  I'll see if I can get the lab to fix it meantime use another cluster

0 Kudos
ArunSkull
1 Copper

Re: Unable to connect to Online Public Cluster

Im also facing the same issue,

using IBM-AIX, set paths, LD_LIBRARY_PATH, everything. but im getting the below error on following ip's

168.159.214.23

168.159.214.11

168.159.214.12

168.159.214.13

168.159.214.14

ClusterCloud::getPrimaryCluster(0)<FPPool::Open(/CenteraInstall/Centera_SDK/TestConnection/Test.txt)<_FPPool_Open(/CenteraInstall/Centera_SDK/TestConnection/Test.txt)<FPPool_Open8(/CenteraInstall/Centera_SDK/TestConnection/Test.txt)

com.filepool.fplibrary.FPLibraryException: no primary cluster found

        at com.filepool.fplibrary.FPPool.<init>(Unknown Source)

        at ConnectionTest.main(ConnectionTest.java:29)

checked with other ip's too.


Kindly help.

0 Kudos

Re: Unable to connect to Online Public Cluster

Hi there, these are working for me.

Did you check your corporate firewall to see if it blocks UDP and TCP on port 3218.  The error you are getting is saying that for some reason you cannot connect to the cluster.  The most frequent cause of this is because your corporate firewalls are blocking UDP

0 Kudos