d1lane
1 Copper

Use of 'neo' with SDK 3.2.705

Until recently our application used Centera SDK version 3.1.477. We used to test with a connection string of 'neo', which wrote to a folder c:\neo_cache. We've now upgraded to SDK version 3.2.705, and we're getting an error if we try to use neo:

ClusterCloud::getPrimaryCluster(0)<FPPool::Open(neo)<_FPPool_Open(neo)<FPPool_Open(neo) no primary cluster found;FP_NO_POOL_ERR.

0 Kudos
5 Replies
mfh2
2 Iron

Re: Use of 'neo' with SDK 3.2.705

Hello -

I can't remember which was the last SDK version to have this feature, but I can confirm that using 'neo' as a connect string no longer works (tested with 3.2.705).

Of course the online test clusters are available to developer network members for testing; connection details are here: EMC Centera Online Clusters (Connectivity Information)

Good luck,

Mike Horgan

0 Kudos
gstuartemc
2 Iron

Re: Use of 'neo' with SDK 3.2.705

Neo was available up to (and including) 3.1p1 but was removed after that. It was never a supported feature and was not intended to be available external to EMC Engineering.

As Mike states, the public clusters are there for testing purposes by developers who do not have access to their own physical cluster.

0 Kudos
d1lane
1 Copper

Re: Use of 'neo' with SDK 3.2.705

We have switched to using EMEA 1. Is there a limit to the size of clip we can create? We are getting ‘not enough capacity’ trying to save 200MB.

Thanks

From: Graham Stuart

Sent: 19 January 2011 11:35

To: David Lane

Subject: New message: "Use of 'neo' with SDK 3.2.705"

EMC Community Network <https://community.emc.com/index.jspa>

Use of 'neo' with SDK 3.2.705

reply from Graham Stuart <https://community.emc.com/people/gstuartemc> in Centera SDK - View the full discussion <https://community.emc.com/message/524445#524445

0 Kudos

Re: Use of 'neo' with SDK 3.2.705

Hmm EMEA1 looks a bit sick.  Try using EMEA2 (C* 4.0) or US2 (C* 4.1)  we should probbaly have EMEA1 taken offline.

Also what PEA file are you using?

0 Kudos
d1lane
1 Copper

Re: Use of 'neo' with SDK 3.2.705

We were using peafile 2 from EMEA1. Peafile 1 gave us an authorization error.

We’ll try EMEA 2.

Thanks

From: Paul McKeown

Sent: 19 January 2011 15:27

To: David Lane

Subject: New message: "Use of 'neo' with SDK 3.2.705"

EMC Community Network <https://community.emc.com/index.jspa>

Use of 'neo' with SDK 3.2.705

reply from Paul McKeown <https://community.emc.com/people/mckeown_paul> in Centera SDK - View the full discussion <https://community.emc.com/message/524538#524538

0 Kudos