Last reply by 04-22-2020 Solved
Start a Discussion
2 Bronze
2 Bronze

Chromebook 11, cursor disappears

I'm seeing the same problem as others with my fleet of Chromebook 11s - students come in with no cursor on the screen and can only work with the keyboard. Rebooting often fixes it, but not always. Connecting a mouse works well, but we don't want to use them. It seems to be happening with the older machines, 2.5 years in service. 

It's a sporadic issue, but I've reproduced it with no extensions (logged in as Guest), and after powerwashing the devices. The one thing I can do to eliminate the problem is move the student to a Samsung or ASUS Chromebook - the problem goes away for good.

Any ideas what could be causing the issue with the 11 model?



Solution (1)

Accepted Solutions

Same here we bought 150, chromebooks 11 (3180) and we have the same issue, they are just poorly built. we want to buy another 150 but no way its going to be dell, samsung or asus. Pity as Dell used to be such a good company, with quality stuff. Unless Dell does something to the ones we have then we are going elsewhere. regards

View solution in original post

Replies (31)
7 Thorium

Hi K.Barker,

Thanks for posting.  Apologies that your systems are having difficulties.

In researching this, it appears to be a software issue, please check the Google references here , here and here.



Thank you, Robert. I've read through all of those posts, and been through all the steps they discuss with no success. The problem always comes back on Dell hardware. If I move the users to an ASUS or Samsung unit, it fixes the problem, so I've isolated my issue to Dell hardware.

Please let me know if Dell decides to look into this issue. We're due to refresh a third of our machines in July, but with this issue affecting more users every week, we'll have to move away from Dell Chromebooks.



I used to have a Dell Chromebook 11 and it would do this from time to time. I would lose functionality of the mouse and have to log out and back in to get it to work. I was using an external logitech mouse. I found that the mouse I had sometimes would have this issue when two usb devices were plugged in and would stop once I unplugged the usb devices. So you might want to check that.


My Dells: Dell Chromebook 13 3380, Alienware M11xR2


Thanks for the idea.

In our case this is happening with no USB devices in the machine at all. In fact, plugging in an external mouse fixes it as long as the mouse stays plugged in. The Chromebook basically thinks it has no mouse or trackpad installed, so it removes the cursor. As soon as it detects the hardware, either an external mouse or the internal trackpad, the cursor returns. But the idea of hundreds of students having to store and manage external mice is enough to give me nightmares, so we don't think that's a workable solution.




Since you have "hundreds of students" with these products, your school or educational facility should have a dedicated Technical Account Manager.  I was assuming you were a home consumer, which is my fault and I apologize for not asking for more detail prior to answering your question.  

Please contact your TAM, (your IT department or the purchasing department will know who that person is) and the TAM is responsible for assisting you, as they have your warranty and account information.  Thanks.



Thank you, Robert. I actually am the TAM and I have all the warranty information. However, these Chromebooks were purchased with only a one year warranty which expired a year and a half ago, which is why I'm not pursuing repair through that channel.


2 Bronze
2 Bronze

Let me know if you found the fix because I have the same issue 



I Have same problems, there is no one to help?



This post does not contain a fix for this issue, but I did want to comment that I believe the cursor disappearing was a "feature" that started after one of the upgrades. I currently own a Chromebook Pixel LS 2015 and I also started seeing this about half a year ago. Things always worked well and then one day, it became intermittent. Hard booting the Chromebook 1-2 times generally fixed the issue for a little while. Technically there could be dust on the track pad or the cabling inside may be a little loose (I was actually debating if mine was static buildup since it is a metal case sitting on carpet), but either way it seems like part of the unit. If it is constantly happening and none of the other troubleshooting techniques fix it for good, then you will need to contact the laptop manufacturer or submit a software bug to Google.

I also wanted to mention that it could also depend on what channel you are running the laptop in. I assume most people run on the stable channel, but I currently run the beta channel build. In the past 1-2 months, I started to get a black screen during bootup (lasts about 6 seconds or so), before displaying the desktop. Again, this is on the beta channel and is a software issue, since it never existed before. Good luck!

Latest Solutions
Top Contributor