Chromebook

Last reply by 04-22-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
191631

Chromebook 11, cursor disappears

I'm seeing the same problem as others with my fleet of Chromebook 11s - students come in with no cursor on the screen and can only work with the keyboard. Rebooting often fixes it, but not always. Connecting a mouse works well, but we don't want to use them. It seems to be happening with the older machines, 2.5 years in service. 

It's a sporadic issue, but I've reproduced it with no extensions (logged in as Guest), and after powerwashing the devices. The one thing I can do to eliminate the problem is move the student to a Samsung or ASUS Chromebook - the problem goes away for good.

Any ideas what could be causing the issue with the 11 model?

 

 

Replies (31)
171713

Same here we bought 150, chromebooks 11 (3180) and we have the same issue, they are just poorly built. we want to buy another 150 but no way its going to be dell, samsung or asus. Pity as Dell used to be such a good company, with quality stuff. Unless Dell does something to the ones we have then we are going elsewhere. regards
31336

Considering most Chromebook manufacturers outsource assembly of their devices to the same offshore companies, I'm not sure what you're hoping to resolve.  The 3180 is no longer in production and has been superseded by the 3100.  From my analysis of this new device's internal design, I don't foresee the same track pad issues being prevalent in this new model.

2 Bronze
2 Bronze
15344

Returning my Dell Chromebook 11.6 3181 today. When in use, the cursor starts flickering and chrome web pages go berserk without touching the screen or keyboard! It is not the settings or my profile; I have tried a few suggestions posted here. Too bad, it was perfect for me but I'm not going to spend any more time with it. Will try a different brand.

31166

Our school switched to 3100s because of the problems with 3180, and almost all of the 3100s get stuck in tablet mode once screen is flipped back so students are forced to only use touchscreen keyboard. Getting very frustrated with Dell chromebooks!

29514

Hopefully the new 3100 resolves this issue.  We will wait and see.

12936

This is the exact reason why the cursors keep disappearing. It's a poor connection between the ribbon cable and the system board. The placement of where the ribbon cable adheres to the chassis on that end puts too much tension on the cable which causes it to come loose (hence why the cursor cuts in and out). It's an easy fix albeit very annoying when you have to do it on hundreds of devices (we have almost 1,000 3180s in our district...). It's just a matter of lifting the ribbon cable off of where it's adhered to the chassis, reconnecting it to the system board, and then laying it back down so it adheres again to the chassis. This relieves that tension that was originally there and prevents it from coming loose again. I brought this to Dell's attention today (albeit it's too late for the 3180) in hopes that they take note of this and rectify any existing devices/prevent it from being an issue in their newer models.

115851

That's great to hear as we should have our first 3100 here this month for testing. We have a huge order to put in this summer and we DO NOT need to run into such a ridiculous issue again.

2 Bronze
2 Bronze
10195

hey, im a current student and this has been happening to me as well. the IT department of the school couldn't fix the problem. I keep rebooting my computer, but im starting to think its a hardware issue. I've read through this stream of comments, and I could not find any helpful solutions. does anyone know of a longterm solution? 

10192

@Amelia Janet 

 

It's a manufacturer's defect. Your IT department needs to re-seat the ribbon cable for the touchpad. If they look where it connects to the system board, it's not fully inserted. They need to take out the battery, detach the ribbon cable where it adheres to the palmrest near the system board, re-insert it fully into the system board and then lay the ribbon cable back down so it adheres to the palmrest again. We've fixed well over a hundred with this issue already and it's always been the same thing.

7776

As I sit here on my Acer Chromebook 15 looking for solutions to the same problem, I'm getting the feeling it's not really a Dell specific issue. My Chromebook is also about 2 years old, and this issue started up very suddenly. Specifically, I had not been using my chromebook for several months, then took it out and ran the update, then I started seeing this issue at least once per day.  

While I'm not saying it was related to the update, it certainly doesn't seem to be isolated to Dell. That actually lends some support to the ribbon theory, as a part like that is likely not manufactured by Dell, but instead by some company in Taiwan that sends them out to multiple computer manufacturers. Furthermore, it was likely a specific production run that had the fault, seeing as most are seeing this issue around the same time in their lifecycle.

Latest Solutions
Top Contributor