Cisco MDS VSAN, Port Channel, related

Jump to solution

Hi,

I have few queries:

1. Anyone know what is the highest # of VSAN iI can have per fabric ? The switches that the VSANs would be created would be at 6.2(5)

Ex: fabric-1 ---> VSAN1 (Admin), VSAN98 (Prod), VSAN198 (Non-Prod), VSAN298 (Test/Dev). Is there any limitation on what the max. we can go upto?

Per Cisco MDS NX-OS Release 5.2 Configuration Limits - Cisco I can have upto 4,000 VSANs per physical fabric, but I'm not sure if I should take it as we being able to create a VSAN3999. Any guidance/ in put into this is welcome

2. Port-Channel creation: If any of you can provide or have step-by-step process for creating a port-channel - that would be helpful.

3. Cisco DCNM . Fabric Manager - which version do you guys recommend? SMI-S support for EMC arrays on MDS - anyone tried that? any benefits?

Thanks!

kach1947

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
dynamox
6 Gallium

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

kach1947_customer wrote:


Thanks Dynamox. Awesome that you are replying so fast

for #2, I have tried from Cisco port channel creation documentation, but just want to see if there are easier (better / time efficient) ways of doing things, especially since people like you have so much expertise in SAN configuration and relevant tasks.

In this example i am creating a port-channel between two MDS switches. You will need to use your own fc interfaces and your own port-channel if you like. This was on a switch that was 4G only, if you have 8G switch you will need to set switchport speed to 8000. I am trunking VSAN 130 between two switches.

on switch 1 run these commands:

config t

interface port-channel 10

channel mode active

switchport speed 4000

switchport rate-mode dedicated

switchport trunk mode on

switchport trunk allowed vsan 130

int fc2/24

channel-group 10 force

no shut

int fc3/24

channel-group 10 force

no shut

perform the same commands on switch 2.

0 Kudos
9 Replies
Highlighted
dynamox
6 Gallium

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

1)http://www.cisco.com/c/en/us/td/docs/switches/datacenter/mds9000/sw/6_2/configuration/guides/config_...

2) what have you tried/read so far ?

3) I am using 6.2.5 ( not messing with SMI-S though)

0 Kudos
dynamox
6 Gallium

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

MDS9513# sh vsan usage

7 vsan configured

configured vsans:1,102,105,109,114,400,500

vsans available for configuration:2-101,103-104,106-108,110-113,115-399,401-499,501-4078,4080-4093

this command tells you what's in use and what can be used.

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution


Thanks Dynamox. Awesome that you are replying so fast

for #2, I have tried from Cisco port channel creation documentation, but just want to see if there are easier (better / time efficient) ways of doing things, especially since people like you have so much expertise in SAN configuration and relevant tasks.

#1 - will read that in a few minutes.

thank you for the command, will try that out.

0 Kudos

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

So I tried and got this:

show vsan usage

1 vsan configured

configured vsans:1, 2

vsans available for configuration:3-4078,4080-4093

which means I can use anything between 3 and 4093 (including those two) - correct?

0 Kudos
dynamox
6 Gallium

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

yes, do not use VSAN 1.

0 Kudos
dynamox
6 Gallium

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

kach1947_customer wrote:


Thanks Dynamox. Awesome that you are replying so fast

for #2, I have tried from Cisco port channel creation documentation, but just want to see if there are easier (better / time efficient) ways of doing things, especially since people like you have so much expertise in SAN configuration and relevant tasks.

In this example i am creating a port-channel between two MDS switches. You will need to use your own fc interfaces and your own port-channel if you like. This was on a switch that was 4G only, if you have 8G switch you will need to set switchport speed to 8000. I am trunking VSAN 130 between two switches.

on switch 1 run these commands:

config t

interface port-channel 10

channel mode active

switchport speed 4000

switchport rate-mode dedicated

switchport trunk mode on

switchport trunk allowed vsan 130

int fc2/24

channel-group 10 force

no shut

int fc3/24

channel-group 10 force

no shut

perform the same commands on switch 2.

0 Kudos

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

Dynamox - thank you.

Glad that those are the same steps I followed., except that I never set the speed to 4000.... I assume if it is left default, it takes the default speed of the port(s) on which we configure the port-channel?

0 Kudos
dynamox
6 Gallium

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

Default is fine, it will auto negotiate.

0 Kudos

Re: Cisco MDS VSAN, Port Channel, related

Jump to solution

Thanks! Will test out 8000 when I work on the same in 8G supported switches in a couple of weeks.

0 Kudos