dpk1
2 Bronze

Brocade segmented switch

I added a HP brocade switch to my fabric.  It is running FOS 6.2.0 and my principles are running FOS 5.2.0.  The new edge switch is showing up as segmented in the left hand GUI.  The OS's are suppose to be compatible.  I cleared the configuration many times on the edge.  I also disabled QOS.  When I pull  up the port on the principle switch it doesn't indicate segmented.  The event log shows no errors.  Do I need to clear out a log so this switch will no longer show up as segmented?  I found a command, fabstateclear, that I thought sounded applicable but I need to make sure it is non-disruptive.  No support from EMC since I'm running an unsupported FOS.  It's end of fiscal year and I'm not upgrading.  Any help would be appreciated.

Labels (1)
0 Kudos
8 Replies
alwaysonline
1 Copper

Re: Brocade segmented switch

check in powerlink if the two OS are suitable for merging..

If so then when you clear the configuration of new switch and when you add a Fiber to the newswitch give the command cfgenable "<effective config name>"

The effective config should get dispersed in the fabric...

If this doesnt happn dont panic...

get the effective config from the fabric giving command " cfgupload ".. download the config to your local system....

If the brocade is new and doesnt hav to be added with anymore zones then just to "cfgdownload" to the new brocade..

If the brocade already has some zones and if you need to preserve those, then do a cfgupload from the new brocade also and then edit the file so that you add the zones to the zones of the config and alias in alias of the effective config switch...

then you can do a cfgdownload of the new editted file..

Hope this answers.

0 Kudos
dynamox
6 Thallium

Re: Brocade segmented switch

domain id's are unique ?

0 Kudos
Allen Ward
4 Germanium

Re: Brocade segmented switch

Also confirm that the ports on both switches are configured to allow "E type" connections. If they are hard coded to "F" you aren't going to get an ISL.

0 Kudos
dpk1
2 Bronze

Re: Brocade segmented switch

I have unique domain IDs and the FOS are compatible.  I have uploaded the zone confiuration either through the upload or the cfgclear more times than I can count.  I have disabled QOS on the OFS 6.2 switches.  I have basically done everything I could find on the internet.  Can I use the switches even though their segmented?  I'm beginning to think it's just showing segmented due to one being 6.2 and the other being 5.2.  I am also wondering if their is a flag I need to clear on the principles?

0 Kudos
dpk1
2 Bronze

Re: Brocade segmented switch

Your going to love this one.  On my PC and the other admins PC the switch shows up segmented in the GUI.  On different PCs it shows up correctly, in with the other switches. This is strating to become fun.

0 Kudos
dynamox
6 Thallium

Re: Brocade segmented switch

one of the reasons i don't trust GUIs.  Run "fabricshow" on each side ..see what it displays.

0 Kudos
Allen Ward
4 Germanium

Re: Brocade segmented switch

I don't distrust GUIs in general, but anything based on Java makes me nervous (which I suppose pretty my amounts to GUIs in general *lol*)

Definitely trust the CLI over the GUI if they don't agree.

0 Kudos
dpk1
2 Bronze

Re: Brocade segmented switch

I ended up running CC Cleaner on my desktop and cleaned up the temp files and registry.  I then rebooted.  Switch now shows up as un-segmented.  I would think grabbing the GUI from the switch would have nothing to do with my desktop caching things but I guess it does.  Thanx everyone for your help.

0 Kudos