DanPJ
2 Iron

DCNM-SAN database won't start

Hello,

When I try to connect to DCNM-SAN I get "Can not connect to DCNM-SAN server".  I also noticed the "postgresql" isn't running. I see the service grabbing port 9099 when it starts but still no database. I see a lot of connection issues in the attached log but this may be caused by the database down, not necessarily the root cause. Are there any database maintenance commands I could run or something to get me closer to my problem?

Thanks.


Labels (1)
0 Kudos
8 Replies
dynamox
6 Gallium

Re: DCNM-SAN database won't start

brute force reboot of the server does not work ?

0 Kudos
DanPJ
2 Iron

Re: DCNM-SAN database won't start

No, tried that.

0 Kudos

Re: DCNM-SAN database won't start

It might be best opening a case with the emc connectivity team after collecting complete logs.

As we need to know the specific version of DCNM that is having issues.

The complete logs can be usually be collected by following the article listed below.

https://emc--c.na5.visual.force.com/apex/KB_HowTo?id=kA0700000004Jz5

The following questions help in understanding the issue you are facing?

- What version of DCNM-SAN are you running?

- At the DCNM-SAN login screen, does the DCNM Server field point to the IP address of the DCNM server, or is it localhost? If it shows localhost, please try changing this to the IP address of the DCNM server. If the IP address of the server is shown in this field, please verify that the correct IP address is displayed.

- Have you tried restarting the DCNM-SAN and Database (Oracle/PostgreSQL) services? Or just rebooted the server itself?

- Is the server a physical or virtual machine?

- Can you also verify that the firewall settings have not been modified? The following knowledgebase article outlines the ports required by Fabric Manager / DCNM and which should be excluded from the firewall:

https://support.emc.com/kb/6005

We also have seen some instances where the Java is the issue and it is advised to uninstall Java completely and re install Java. Once the Java is re install make sure to reboot the server and try connecting the DCNM server.

One additional article

You might check the following article also in case its relevant https://support.emc.com/kb/88386

0 Kudos
Highlighted
DanPJ
2 Iron

Re: DCNM-SAN database won't start


It's starting to look like the Netbackup Client install clobbered the database. Have you ever heard of this?

0 Kudos
DanPJ
2 Iron

Re: DCNM-SAN database won't start

We found the problem. Symantec provided a new install MSI that does not clobber the PostregSQL Dbase.

Thanks!

0 Kudos
dynamox
6 Gallium

Re: DCNM-SAN database won't start

what was it doing to the database ?

0 Kudos
DanPJ
2 Iron

Re: DCNM-SAN database won't start

Looks like the Netbackup client install actually uninstalled the PostgreSQL database that was owned by DCNM. I shouldn't be surprised, Symantec is famous for assuming that we only want to run their software.

0 Kudos
dynamox
6 Gallium

Re: DCNM-SAN database won't start

ahah..what ?

0 Kudos