admingirl
3 Zinc

virtual HBAs only showing port address set A in fabric

Jump to solution

Hello,

We have just started using virtual HBAs for our new Hyper-V environment. Here is what the Windows admin told me to look for after he did what he needs to do on his server.

VSAN 100 (HBA1)

port address set A

WWNN: C003FF0000FFFF00

WWPN: C003FF7748AD0000

port address set B

WWNN: C003FF0000FFFF00

WWPN: C003FF7748AD0001

VSAN 200 (HBA2)

port address set A

WWNN; C003FF0000FFFF00

WWPN: C003FF7748AD0002

port address set B

WWNN: C003FF0000FFFF00

WWPN: C003FF7748AD0003

I AM ONLY SEEING THE WWPN FOR PORT SET A IN BOTH VSAN 100/200. I AM NOT SEEING THE HBAS FOR PORT SET B.

I thought I see both port set A and B in each each VSAN. Is there something else he needs to do on the windows server? Or is it a problem with the fabric?

Many thanks!

Admingirl


Labels (1)
0 Kudos
22 Replies
Roger_Wu
5 Tungsten

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

I noticed your tag so you're using Cisco MDS switches? Have you enabled NPIV on it? Maybe you can refer to this first:

Cisco MDS 9000 Family NX-OS Interfaces Configuration Guide - Configuring N Port Virtualization  [Cis...

dynamox
6 Thallium

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

4 adapters are needed for failover but i don't think the second pair comes online until after you "failover" that VM to another host. Have them perform Live Migration to another host and see if the other set logs-in.

0 Kudos
Highlighted
Sridhar246
2 Iron

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

Port set B is brought online only in case of live migration and vice versa.

Let's say your VM is sitting on node-A with port set A, when you live migrate this same VM to node-B hyper-V will actually bring port set B online on node-B migrate the VM resources and then bring port set-A offline, and similar operation happens when you failback.

So what you are seeing is normal. I would recommend testing live migration, many times VM won't live migrate because of zoning issues.

admingirl
3 Zinc

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

Hi,

How to I zone the B side for failover testing. Since they don't automatically appear in the fabric, would I manually add them to the fabric, or array? Someone who had done this before using brocades said he had to manually add the B side.

Benita

0 Kudos
dynamox
6 Thallium

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

manually create fcalias/device alias and zones. Then manually create initiator records on VNX (WWNN:WWPN format)

0 Kudos
Sridhar246
2 Iron

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

Both zoning and registering with VNX will have to be done manually.

0 Kudos
admingirl
3 Zinc

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

Hi,

I am not using fcaliases. I ran the sh fcalias vsan 100 and got no alias present. I would assume then I just create a device alias and then zone.

0 Kudos
dynamox
6 Thallium

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

must be using device aliases ?

sh device-alias database

admingirl
3 Zinc

Re: virtual HBAs only showing port address set A in fabric

Jump to solution

Yep, device alias it is!

0 Kudos