kulcheski
1 Nickel

Dell/Alienware Warranty claim being completely ignored. No Reply in almost 2 weeks.

Hi There,

I have been having an issue with my Alienware Graphics Amp since January. I called in and spoke with someone who claimed my computer was the issue. Not having another alienware device to connect the proprietary cable to, I was unable to properly test the device. A few weeks ago I was able to get a new Alienware 17 as well as a friends Alienware 15 to test the Alienware graphics amplifier on. Upon turning it on, it was noticable the power supply doesn't power on at all, no lights, no fans, no nothing. 

I spent 2 hours on the phone between holds and between a customer service rep giving me a complete run around, and not knowing any product knowledge on the item I purchased. Finally I was able to get a single email from the rep that said...
"

Alienware Support — Service Tag   FROM THE COMPUTER

Your Service Request 

Contact Us | Support Library | Download Center | SupportAssist | Community Forums

 

Hi

We hope you are doing great

I am taking ownership of your case in order to reach a successful resolution

Please send me this info

Service Tag // Express Service Code from the system you are using with 

Pics over device manager using the amplifier // where we can see the video cards  

All the specs from the Video cards is using with the amplifier

if cables got lights or not when removes the video card

the amplifier turn on or not at all connected on the computer

 The next update about your case will be provided through email in 2 business days. However, you can always reply directly to this email and I will contact you as soon as possible.

For additional FAQs (frequently asked questions), visit the Alienware Top Solutions Support page.

Thank you for choosing Dell,

Gustavo Escalante 
Dell | Technical Support "

I kept the Rep on the phone while I quickly took all photos and sent the required information. He told me I would hear back within 24 to 48 hours, no problem. 

It has now been 13 DAYS without getting a single reply, I have followed up 3 times now, as well as sent forward copies to several different customer service emails, and not one single reply from anyone at Dell/Alienware. My warranty is slowly running out as I get competely ignored. I have had issues with Dell's customer service years ago with an Alienware laptop, but everyone atleast responded promptly. Is this what Dell's customer service has become? Ignoring paying customers until their Warranty runs out or they give up from frustration?

Hopefully the right person reads this and I can get some sort of resolution, from here on I will be avoiding Dell like the plague, and telling friends, family, co workers, and clients to do the same. This is by far the worst communication I have ever experienced with any company.




0 Kudos