Highlighted
gunnar_branzke
1 Nickel

DD6300 - failed to add new static route

Hello,

actually it is not possible to add a new entry fpr a static route for a new generated interface on DD63300.

Error :

Route command system error.

Usage: route [add|del] [net|host] target[/prefix] [netmask Nm] [gw Gw] [dev If] [table Tbl]

My Command on CLI:

route add -net 172.17.10.0 netmask 255.255.255.0 gw 172.17.10.1 veth1.10

static route for a s

Why i can't add a new static route for the configured virtual Interface vet1.10 ????

Actual Configuration:

Table: main

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

0.0.0.0         192.168.3.1     0.0.0.0         UG    0      0        0 eth1d

127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo

172.17.10.0     0.0.0.0         255.255.255.0   U     0      0        0 veth1.10

192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1a

192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1d

192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 ethMa

IPv4 Default Gateways

gateway IP    source

-----------   ------

172.16.11.1   static

192.168.3.1   dhcp

-----------   ------

kind regards

Tags (1)
0 Kudos
8 Replies
8 Krypton

Re: DD6300 - failed to add new static route

The command reference docs are incorrect and do not reflect changes made in DDOS6, I've requested an update to them.

You need;

net route add net 172.17.10.0 netmask 255.255.255.0 gw 172.17.10.1 dev veth1.10

That should work for you I think, the outputs don't really drive you to this subtle change but hopefully we'll be back on track with the docs soon.

HTH, Jonathan

0 Kudos
gunnar_branzke
1 Nickel

Re: DD6300 - failed to add new static route

hello jbrooksu,

if i entered your command the cli-output is as follows:

Route command system error.

RTNETLINK answers: File exists

0 Kudos
8 Krypton

Re: DD6300 - failed to add new static route

I recently deployed one DD6300 and I did this via GUI which changed a bit - didn't do over CLI.  I do not have access to it now, but I used 6.0.30 DDOS if I remember correctly and I actually added default route and the specific route for interface only. 

0 Kudos
gunnar_branzke
1 Nickel

Re: DD6300 - failed to add new static route

configuration via GUI results in the same error.
activating static route for a specific interface is not possible --> BUG ???
I will create/opened a support-case for this.

0 Kudos
8 Krypton

Re: DD6300 - failed to add new static route

Check https://support.emc.com/kb/305970  I find a bit strange that file already exist message and it seems to be answered in that KB.

0 Kudos
8 Krypton

Re: DD6300 - failed to add new static route

Hi!

I don't see why do you want to define a static route (and gw??) to 172.17.10/24..

You already have an interface in this network:

172.17.10.0     0.0.0.0         255.255.255.0   U     0      0        0 veth1.10

veth1.10 will be used for outgoing traffic to this subnet by default.

0 Kudos
cfizz34341
1 Copper

Re: DD6300 - failed to add new static route

any update?  i am also getting the same message but is that because it already exists?

0 Kudos
Dan2904
1 Copper

Re: DD6300 - failed to add new static route

I do not have access to it now, but I used 6.0.30 DDOS if I remember correctly and I actually added default route and the specific route for interface only. Popeyes Survey

0 Kudos