Highlighted
angrydok
6 Indium

DPA 6.0

Guys I need a link to the administration/installation guide - as the only I can find are for 5.7 which are not valid for Linux DPA Collector commands....

I need to delete DPA collector from AVE and then re install it, or possibly reconfigure it as the DPA server changed.

Thank you in advance.

0 Kudos
5 Replies
8 Krypton

Re: DPA 6.0

The DPA 6 documentation is at support.emc.com

You shouldn’t need to uninstall/reinstall the DPA Agent to point it to a new DPA Server

In the Agent install directory, typically, /opt/emc/agent/etc, there is a dpa.config file – update the DPA Server hostname in that file and restart the DPA Agent.

If you need the exact line to change in dpa.config, then let me know but it should be obvious ☺

HTH

angrydok
6 Indium

Re: DPA 6.0

I do not have DPA server line in the dpa.config..... here is the full file

#!/bin/sh

#

# EMC Data Protection Advisor configuration data

#

# (c) 2005 - 2013 EMC Corporation. All rights reserved.

#

# $Id: dpa.config 69320 2013-02-07 15:55:24Z cungj $

#

BASE=/opt/emc/dpa/agent

# Path to Oracle Client libraries

AGENT_ORACLE_CLIENT_PATH=

export AGENT_ORACLE_CLIENT_PATH

# Path to NetBackup Install Location

NBUPATH=/usr/openv

# Path to Networker Install Location

NSRPATH=/usr/bin

# Path to OmniBack Install Location

DPPATH=/opt/omni

# Path

PATH=$BASE/bin:$BASE:$NSRPATH:$NBUPATH/netbackup/bin:$NBUPATH/netbackup/bin/admincmd:$NBUPATH/volmgr/bin:$DPPATH/bin:$DPPATH/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin:$PATH:INSTALLGSTBINDIR

export PATH

# Setup NLS_LANG to ensure we use UTF8 - DO NOT CHANGE THIS

NLS_LANG=AMERICAN_AMERICA.UTF8

export NLS_LANG

# Setup Library Path

LD_LIBRARY_PATH=$BASE/lib:$AGENT_ORACLE_CLIENT_PATH

export LD_LIBRARY_PATH

#

# End of file

#

0 Kudos
8 Krypton

Re: DPA 6.0

Just checked, in DPA 6 it has changed to this file :

/opt/emc/dpa/agent/etc/dpaagent_config.xml

May also be best to remove the agent_repq.db file from /opt/emc/dpa/agent/data as well

0 Kudos
angrydok
6 Indium

Re: DPA 6.0

already found that - but no good, so I re installed dpa colletor. Now agent's log is clear and no errors - dpa console however still does not display any info and does not generate reports... (actually it does but all the reports are empty)

0 Kudos
8 Krypton

Re: DPA 6.0

Ok, perhaps all the pfiles needed to be deleted as it does store some parameters. As you reinstalled, the old pfiles would be deleted and start with new ones anyway ☺

As such, this would also mean that the data collection will start from the time of re-installation onwards. It does not automatically retrieve historical information.

If you have further issues, please open an SR with EMC Support.

0 Kudos