Highlighted
kmbay
2 Bronze

How to set up 2nd Avamar system with DPA

Jump to solution

We currently have 2 Avamar and Data Domain systems.

Our main Avamar and Data Domain is already set up with DPA and generating reports.

Our 2nd Data Domain system I was able to easily add in DPA however our 2nd Avamar system I am not able to. When I run Discovery, it does not find our 2nd Avamar. How do I add our 2nd Avamar in to DPA so I can monitor those VMs, backups etc as well?

Thank you!

0 Kudos
1 Solution

Accepted Solutions
lauren_d
1 Nickel

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

Go to the data collection tab and select the jobmonitor collection. Click the edit button. Click the + sign next to Data collection agent.

data colecti.PNG.png

Click the radial button next to Remote and then click the Select Data Collection Agent button. Select an agent server from the drop down menu and click the OK button. Do this for all three data collection requests.Then click the apply button.

Run the data collection in debug again. if it shows returned rows then data collection is working, if not then open a ticket with support as this will require further troubleshooting.

0 Kudos
8 Replies
lauren_d
1 Nickel

Re: How to set up 2nd Avamar system with DPA

Jump to solution

Kaybay,

When you say it does not find the 2nd Avamar, I assume that the test during discovery failed. This may be caused by several issues. Best course of action is to finish the discovery of the 2nd Avamar even though the test fails. Once you have done that you can run the data collection in debug and to get the cause of the connection issue.

Go to Inventory>Object Library>Applications> select he Avamar that is not working.

  In the popup box, click on the Data Collection tab, and select the jobmonitor request. Right Click on the Run button and select Run in Debug.

  Click close on the popup box.

  Click the history button, and select the request history you just ran (it should be the top one).

  In the bottom pane, click the download link on the right side, and save the zip file.

The agent log file in the zip folder should give an error as to why the Avamar is not connecting.

If you do not find an answer in that log then open a Service Request with DPA Support, provide that zip when you open the SR will make allow faster solution.

Lauren

0 Kudos
kmbay
2 Bronze

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

Thank you. Previously I did not go through and finish, I just stopped at the Start Test phase.

This time I went to Discovery Wizard - choose Backing Application, EMC Avamar and entering the hostname of our DR location Avamar (our 2nd avamar system). I start the test and it returns with following error:
Performing tests for EMC Avamar:

Test failed! Unable to connect to host with the given host name and aliases. Please, verify that the DPA server has access to the host with the name and aliases.

Even though it failed with that, I still proceeded through all the other steps till Finish when is said "Discovery is complete. The system automatically added the discovered objects to the Object Library and selected destination groups."

After running the Debug as you suggested I get the following error:
Time : 5/2/2017 2:04 PM Eastern Standard Time Log Level : INFO Message : Request run created by component "ModTest Request"
Time : 5/2/2017 2:04 PM Eastern Standard Time Log Level : ERROR Message : No collector is installed or collector configuration is unavailable

0 Kudos
lauren_d
1 Nickel

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

OK so DPA cannot resolve the host name or alias you provided, or that IP did resolve but DPA was not able to  reach that server. Check that the agent you are assigning to do data collection can telnet to port 5555 with that hostname. If it cannot then this is a network issue and network connectivity will need to be resolved by your network team.

If it can then we need to further trouble shoot this issue. Please open a Service Request with DPA support so we can work this issue for you.

Lauren

0 Kudos
kmbay
2 Bronze

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

How do I check the Data Collection Agent? DPA was set up for us by EMC so I cannot even recall how our 1st production Avamar was set up to integrate with DPA. Although oddly enough our DR (2nd) Data Domain was found and discovered. It is just our DR Avamar that is not.

0 Kudos
lauren_d
1 Nickel

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

When you are running the discovery wizard you have to select the agent for data collection, you get the option of local or a remote agent. IF you selected Local this will not work with Avamar, so select remote and select one of the agents form the drop down box.

That is the agent server we need to check.

0 Kudos
kmbay
2 Bronze

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

dpa.JPG.jpg dpa1.JPG.jpg

I only get Local Agent option - Remote is grayed out. On Next I get that 2nd pop up error.

I went to our DPA collector server and ran telnet to our 2nd avamar on port 5555. It opened a telnet window to that Avamar server.

I went back to DPA and ran a Job Monitor debug and I received the same failure errors:

No collector is installed or collector configuration is unavailable.

This is b/c I noted in Inventory that this Avamar is using itself (own hostname) as Collector Agent rather than my specific DPA server (as my 1st Avamar system correctly is).

How do I get my DPA to allow me to use the Remote Agent option so I can select the correct DPA Server Collection agent vs a non-existent agent on the Avamar system? Or rather now that I've already discovered this 2nd Avamar and it is listed in Inventory, how do I configure it to use my Data Collector Agent rather than it's own server name?

0 Kudos
lauren_d
1 Nickel

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

Go to the data collection tab and select the jobmonitor collection. Click the edit button. Click the + sign next to Data collection agent.

data colecti.PNG.png

Click the radial button next to Remote and then click the Select Data Collection Agent button. Select an agent server from the drop down menu and click the OK button. Do this for all three data collection requests.Then click the apply button.

Run the data collection in debug again. if it shows returned rows then data collection is working, if not then open a ticket with support as this will require further troubleshooting.

0 Kudos
kmbay
2 Bronze

Re: Re: How to set up 2nd Avamar system with DPA

Jump to solution

That did it. Thank you Lauren!!

Can I correctly assume that the DPA will only start collecting backup data from this point on for my 2nd Avamar and no data prior to today?

0 Kudos