JaShaw01
Copper

DellBIOSProvider 1.2 on Optiplex machines issuing Import-Module Error

Good Day,

I'm having a bit of an odd problem.  I attempting to use the DellBIOSProvider 1.2 powershell module.  I setup a PDQ Deploy script, tested on my Latitude, to copy the module, import the module, and get the WakeOnLan status.

The script worked successfully on all of our Latitude machines and failed with the same error on all of our Optiplex machines (various models).

The error output from PDQ is "Import-Module : Could not load file or assembly 'DSMBLibWrapper.dll' or one of its dependencies. The specified module could not be found.".

To troubleshoot, I remoted into one the machines and tried the import manually.  I do not get an error with the import-module, but it doesn't install the Dellsmbios PSDrive either.

What am I missing?

0 Kudos
2 Replies
Highlighted

RE: DellBIOSProvider 1.2 on Optiplex machines issuing Import-Module Error

Hello JaShaw01,

Please check if all the prerequisites are met. Systems must have VS2010 and VS2012 redistributables installed. 

In case all prerequisites are met already, please let me know model names on which error is coming. Also let me know verbose output during import-module command.

Thanks

-Tarun

[tag:IWork4Dell]

Tags (1)
0 Kudos
JaShaw01
Copper

RE: DellBIOSProvider 1.2 on Optiplex machines issuing Import-Module Error

Ok...  Problem solved.  The issue was architecture.  I had checked for the 2010 & 2012 redistributable packages but I was missing the correct architecture for the 2012.  Because I have all of these pushed through deployment by group, I was missing that package across the whole group.  

Thanks for pointing me back in the right direction.

0 Kudos