Bcf4445
1 Copper

Unable to import Dell PowerShell Provider 2.0.0_280 module within WinPE

I'm setting up an SCCM OSD and each time I try to import the module, I get the error: "Could not load file or assembly 'DSMBLibWrapper.dll' or one of its dependencies. The specified module could not be found."

I've tried both the direct download from Dell's website and a saved copy from the PowerShell Gallery.

After researching this, everything points to missing DLLs for the Visual C++ Runtime, but I'm unable to find clear guidance to resolve this. Other threads specified the 2010 and 2012 versions were needed, but after searching, I found one person who resolved this by replacing 2012 with 2015.

https://www.ladewig.com/dell-powershell-provider-2-0-requires-visual-c-2015/

Confusingly, Dell's documentation isn't consistent. On the Prerequisites page, one column specifies 2010 and 2015, while the next specifies 2010 and 2012:

http://www.dell.com/support/manuals/us/en/04/command-powershell-provider-v2.0/dellcommandpowershellp...

Under the WinPE page, it again specifies the 2010 and 2012 files:

http://www.dell.com/support/manuals/us/en/04/command-powershell-provider-v2.0/dellcommandpowershellp...

My guess is that I need 2010 and 2015, but I'm not having luck when I tried copying over the files specified in that first link. I haven't found any documentation specifying how I should be copying those files over. What I have been doing is installing those runtimes on my machine and then copying those files over from "C:\Windows\System32" into the root of the DellBIOSProvider folder. Is there a cleaner way to do this that I'm just not aware of? Or is there something else I'm doing wrong / not aware of?

For reference, I'm running WinPE 10 x64 generated from ADK 1709 via SCCM 1710.

Best,
Bryan

0 Kudos