Dell OpenManage Enterprise

Last reply by 04-01-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1915

Dell Repository Manager unable to download catalog file

I have been trying to create a custom firmware bundle using Dell Repository Manager 2.2.4 but it is not working since last few days.

Last Friday (12/March/2021) the url https://downloads.dell.com/catalog/ was broken and not working but today it is working but catalog is not getting updated on my machine.

 

PS: I have tried running DRM from different machines but everywhere it is failing. i have created new bundles several times in the past but today it is not working..

Here is the log file which shows something must be broken somewhere.

16-03-2021 13:43:32 Error in loading new repository A duplicate value cannot be inserted into a unique index. [ Table name = BundleSystem,Constraint name = PK__BundleSystem__0000000000000350 ] at System.Data.SqlServerCe.SqlCeResultSet.InternalInsert(Boolean fMoveTo, Object sender, SqlCeUpdatableRecord record)
at System.Data.SqlServerCe.SqlCeResultSet.Insert(SqlCeUpdatableRecord record)
at RMDataServiceLibrary.RMDatabase.LoadEntity.WriteEntity(SqlCeCommand command, EntityObject entityObject) in Libraries\RMDataServiceLibrary\RMDatabase\LoadEntity.cs:line 249
at RMDataServiceLibrary.RMDatabase.LoadEntity.WriteEntities(List`1 entityObjects) in Libraries\RMDataServiceLibrary\RMDatabase\LoadEntity.cs:line 144
at RMDataServiceLibrary.RMDatabase.LoadContext.BeginLoading(Boolean isMerge) in Libraries\RMDataServiceLibrary\RMDatabase\LoadContext.cs:line 76
at RMDataServiceLibrary.DataServiceAPI.ImportCatalogController.AltMainCatalogImporter(String catalogPath, String signPath, Nullable`1 sourcePublishDate, RepoCode repoCode, Func`2 checkNetworkConnection, Boolean console_flag) in Libraries\RMDataServiceLibrary\DataServiceAPI\ImportCatalogController.cs:line 135

 

 

 

 

Replies (7)
1900

Hello @Prakash_K,


Can you try to use answer version of DRM? Please, check this link to the official article: Support for Dell EMC Repository Manager (DRM) https://dell.to/3llXe7u You can see here, the latest version is 3.3.1. Here you can find the download link: https://dell.to/3ljDrpo


Please, let us know if you have the same issues with the latest version.


Regards.


Diego López
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
1854

I have been able to use both versions in the past and have created repositories several times but this time none of the versions (3.3.1 or 2.2.4)  is working. When I try creating a Repo from 3.3.1 the progress wheel kept on spinning forever and never completed.

I tried downloading the catalog.xml.gz file from internet and tried importing that file too in DRM 2.2.4 but it fails with following error.

Job Name: Import Repository
Job Status: Failed

Job Result:

A duplicate value cannot be inserted into a unique index. [ Table name = BundleSystem,Constraint name = PK__BundleSystem__0000000000000350 ]
Location: C:\Users\prakakum\Desktop\Catalog.xml.gz
1844

Hi.

 

It looks like something is broken in the DRM SQL database on your system.

Could you please remove all versions of DRM from your system and do a clean install.

 

BR
Stefan



DellEMC

Stefan Richter
Community Manager
Brand certified, SMaC Professional


1541

I have tried uninstalling and reinstalling and even I did a fresh install on a new machine alltogather, still the issue is same.

3 Argentum
1843

Hi, You should try a new version of DRM because this might be the reason behind error in downloading catalog file.

1538

There are two different versions out there 2.2 and 3.3, Can someone tell me if the older one (2.2) is going to be discontinued by Dell as I did not see any thing as such mentioned anywhere.

1498

Hi,

DRM 2.2 is discontinued by Dell which should be pulled off soon from Dell Support site.

It is recommended to use latest Dell EMC Repository Manager 3.3.1 version.

https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=4d32v 

 

Latest Solutions
Top Contributor