bcshort
2 Iron

OM Enterprise 3.1 Ignoring Proxy Setting

Jump to solution

Hi,

I have an OM Enterprise 3.1 instance that is behind a corporate proxy.

I have configured the proxy settings under Application Settings > Network > Proxy settings - Correctly configuring each field.

It appears that the appliance is not using this setting at all:

  • Console update fails with a CAPP1122 error
  • Push Notifications do not happen - "notification service status encountered an error - null"

I have set up packet traces between the appliance and the proxy and there is no traffic coming to the proxy from the appliance IP. There are no firewalls between the two devices.

While I am waiting for pro support to sign the FSD certificate for me so I can access the shell, does anyone else have experiences with setting the proxy in OM Enterprise 3.x?

 

0 Kudos
1 Solution

Accepted Solutions
anilkumarvkr
2 Bronze

Re: OME 3.2 Available

Jump to solution

@bcshort 

We have fixed upgrade through proxy in 3.2 Release. For Future releases console upgrade can be performed through Proxy

As of now please perform the console upgrade through internal share.

Thanks,

Anil Kumar V K R 

Dell EMC

 

9 Replies
Moderator
Moderator

Re: OM Enterprise 3.1 Ignoring Proxy Setting

Jump to solution

Hello

I show that this is a known issue that is going to be addressed in a future version of OpenManage Enterprise. I think this is the thread where it was reported. Workarounds are also discussed in the thread, manual/offline via NFS is the recommended method until this issue is resolved.

https://www.dell.com/community/Dell-OpenManage-Enterprise/Upgrade-OME-from-3-0-to-3-1/td-p/6244290

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

0 Kudos
bcshort
2 Iron

Re: OM Enterprise 3.1 Ignoring Proxy Setting

Jump to solution

Thanks Daniel,

I had seen that article, but didn't realise it applied to 3.1 as well.

Is there advice you can give about push notifications failing? or is that another known issue?

0 Kudos
Highlighted
Moderator
Moderator

Re: OM Enterprise 3.1 Ignoring Proxy Setting

Jump to solution

OpenManage Mobile is accessed over the WAN, it would also be affected by the proxy issues.

Daniel Mysinger
Dell EMC, Enterprise Engineer

0 Kudos
bcshort
2 Iron

Re: OM Enterprise 3.1 Ignoring Proxy Setting

Jump to solution

Hi Daniel, All

As an update to this, I deployed a fresh OVF of the 3.1 appliance this morning and the mobile push notifications work from from this new machine.

The key difference between the old appliance and the new appliance is that the old appliance was upgraded from 3.0 to 3.1 using the console update (local path) workflow that is documented elsewhere on this site.

I am uncertain if the mobile push issue manifested itself before or after the upgrade.

I am continuing investigation with Dell Enterprise Support, as the idea of redeploying the appliance without being to backup/restore existing configuration is not ideal.

 

0 Kudos
bcshort
2 Iron

OMEnt will not update behind proxy

Jump to solution

This does not appear to upgrade from a 3.1 Appliance at all behind a corporate proxy. I have no way to connect directly to the internet.

I pulled the files from the http://downloads.dell.com/openmanage_enterprise/ site to host on a local server for an offline update as I have done previously to go from 3.0 to 3.1, however this has not worked. Placing wireshark on the web server saw NO IP traffic at all from the OME host.

I just spun up at 3.0 appliance, and pointed it to my offline file location and it detected and installed the 3.2 update straight away.

My faulting 3.1 appliance has only just been set up over the last 3 days, following my previous issues with OpenManage Mobile (which I posted on this forum about) after Pro Support's advice was to rebuild.

You can understand that I will be pretty annoyed if I have to rebuild again, as will my boss who is wondering why I need to keep rebuilding the "Enterprise" platform.

0 Kudos
Sidrew
1 Copper

Re: OME 3.2 Available

Jump to solution

Does updating work through a proxy server?  Mine never seems to find this available update via proxy.

0 Kudos
bcshort
2 Iron

Re: OME 3.2 Available

Jump to solution

It never works doing an automatic, online update through the proxy.

It seems to for manual, offline to an internal server - verified this by using Fiddler, so go figure.

 

Came back to it the next day (today), and the manual offline update was available, but that has caused it's own headaches that I am just rolling back from.

Open Manage Mobile now times out trying to connect to 3.2 after accepting the certificate.

0 Kudos
Moderator
Moderator

Re: OME 3.2 Available

Jump to solution

@bcshort wrote:

It never works doing an automatic, online update through the proxy.


Proxy issues were supposed to be resolved with 3.2, but I don't see them in the fix list. They may have been pushed back to a later release. Try deleting the proxy settings and recreating them.

https://www.dell.com/support/home/drivers/driversdetails?driverid=8PM2K

Daniel Mysinger
Dell EMC, Enterprise Engineer

0 Kudos
anilkumarvkr
2 Bronze

Re: OME 3.2 Available

Jump to solution

@bcshort 

We have fixed upgrade through proxy in 3.2 Release. For Future releases console upgrade can be performed through Proxy

As of now please perform the console upgrade through internal share.

Thanks,

Anil Kumar V K R 

Dell EMC