ARS2014
1 Nickel

OME Authentication Error

Jump to solution

Hi all,

I have been receiving numerous Authentication Error alerts from my Domain Controller. After doing some digging I found that even though I had set up the SNMP service on the DC to accept alerts from the IP of my Essentials server, it was saying I had an unauthorized server sending SNMP requests.

This is how I learned that somehow the Essentials server was attempting to connect to the DC via SNMP from a different IP than the IP of the virtual switch configured to communicate with the LAN. It was attempting to use the IP of the switch configured to communicate with my SAN. 

I was wondering if anyone else has experienced this issue of OME attempting to use the incorrect Ethernet adapter and if so what did you do to resolve this issue?

Thanks.

0 Kudos
3 Replies
Highlighted

Re: OME Authentication Error

Jump to solution

Hi, thanks for the query.

Please help with below information.

  1. What version of OME is being used?
  2. Is ICMP ping enabled in the environment and same allowed in OME?

Thanks,
Shivendra

0 Kudos
ARS2014
1 Nickel

Re: OME Authentication Error

Jump to solution

Hi Shivendra,

Thanks for the reply.

I am running OME v 2.5.0.1005 and yes ICMP is enabled.

 

Let me just clear some things up. The DC is a physical server whereas the OME server is virtual. After doing some packet sniffing on the OME server, I found the SNMP packets are not traveling through the SAN at all which is expected since there is no route for them to make it to the DC from there.

The SNMP packets are traveling through the correct LAN Ethernet port carrying an agent-addr IP of the SAN Ethernet port. As far as I can tell there is no way to manually set the agent address nor is there a way to configure which Ethernet port the SNMP packet is sent from. This is the heart of our issue, is there any way to configure SNMP to use a certain Ethernet port or IP? Seems like this would be a very helpful feature.

0 Kudos

Re: OME Authentication Error

Jump to solution

I am afraid such configuration is not available in OME. I'll pass on this valuable feedback to the concerned team.

Thanks,
Shivendra

0 Kudos