Highlighted

OME Client Communication

Just came into this OME environment and I'm having issues.

Does not appear to be updating client information - mix iDRAC 6 and 7 - 710's and 720's.

 Device by status is Unknown, Alerts by Severity is No Data Available.

Error when trying to do updates is immediate (WinRM client cannot process - Basic authentication is currently disabled in client configuration........)

I updated an iDRAC manually but is not reflecting in System Update.

The iDRAC is reachable from the OME server and troubleshooting tool using WSMAN connects with following results. Any help would be appreciated

Using TLS 1.0 for SSL/TLS handshake.
TLS 1.0 Handshake successful.
Connected.
WSMAN profiles found on the remote device are:
1. OS Deployment
2. Software Inventory
3. Software Update
4. Job Control
5. LC Management
6. Persistent Storage
7. Simple NIC
8. Simple FC
9. BIOS and Boot Management
10. Simple RAID
11. Fan
12. Power Supply
13. iDRAC Card
14. Memory
15. CPU
16. System Info
17. PCI Device
18. Video
19. Base Server
20. Service Processor
21. SM CLP Admin Domain
22. Power State Management
23. Active Directory Client
24. Simple Identity Management
25. Role Based Authorization
26. Record Log
27. DHCP Client
28. DNS Client
29. Ethernet Port
30. IP Interface
31. Command Line Protocol Service
32. Physical Asset
33. Base Metrics
34. Virtual Media
35. USB Redirection
36. Power Utilization
37. SMASH Collections

 

0 Kudos
6 Replies

Re: OME Client Communication

Hi, thanks for the query.

Enable the Basic authentication level. (ref OME FAQ)

The Client configuration should match the settings below:

winrm get winrm/config/client

Client
NetworkDelayms = 5000
URLPrefix = wsman
AllowUnencrypted = false
Auth
Basic = true
Digest = true
Kerberos = true
Negotiate = true
Certificate = true
CredSSP = false
DefaultPorts
HTTP = 5985
HTTPS = 5986
TrustedHosts

This can also be verified using Troubleshooting tool bundled along with OME v2.5.

Run the following command to enable this:

winrm set winrm/config/service/auth '@{Basic="true"}'

Thanks,
Shivendra

0 Kudos

Re: OME Client Communication

C:\Windows\system32>winrm set winrm/config/service/auth @{Basic="true"} WSManFault Message ProviderFault WSManFault Message = The config setting Basic cannot be changed because is controlled by policies. The policy would need to be set to "Not Configured" in order to change the config setting. Error number: -2144108406 0x8033808A Cannot change GPO controlled setting. I changed the GPO locally but I got the same error.
0 Kudos

Re: OME Client Communication

Please work with your GPO administrator.

Thanks,
Shivendra

0 Kudos

Re: OME Client Communication

GPO appears correct locally on the server, can domain GPO still have an affect? - anything else I can try?

Thank youOME_GPO.PNG

0 Kudos

Re: OME Client Communication

This has been resolved - Domain GPO was resetting local setting after login session ended.

0 Kudos

Re: OME Client Communication

Thanks for the update. Smiley Happy

Thanks,
Shivendra

0 Kudos