Highlighted
jkazbill
6 Indium

OME System Update Failure

I've been looking through the forums, but I've been having trouble finding a solution to my issue.

Basically, OME is failing to successfully push system updates to at least one of my systems (PE R410).  Initially, there were about 10 updates for the system and 8 of those installed successfully.  Remaining are a NIC firmware update and the BIOS update.  Below are the version numbers for the updates as well as the error messages.

  • BIOS:
    • Current version:  1.9
    • New version:  1.11
  • Broadcom BCM5716C NetXtreme II GigE
  • Current version:  6.0.1
  • New version:  7.2.20

 

PackageCode  1
PackageFileName  C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\s2uc\Network_Firmware_H15FK_WN_7.2.20_A00.EXE
PackageLog  << PACKAGE LOG (SelfExtractable) >>

=======================> Update Result <==========================

Update was not applied

=========================================================================

Exit code = 1 (Failure)

2013-05-21 12:25:15

<< PACKAGE LOG (SelfExtractable) >>

==========
PackageReleaseId  Not Available
PackageState  complete
PackageStatus  5
TotalStatus  One or more Update Packages failed during execution, but the update continued running to the end.
TotalStatusMessage  Software update complete.

############################################################################

PackageCode  1
PackageFileName  C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\s3jg\BIOS_VHP27_WN32_1.11.0.EXE
PackageLog  << PACKAGE LOG (SelfExtractable) >>

wer than the currently installed version.

   Software application name: BIOS

   Package version: 1.11.0

   Installed version: 1.9.0

 

Executing update...

Device: BIOS, Application: BIOS

   doDepcheck failed

==============================> Update Result <==========================

Update was not applied

=========================================================================

Exit code = 1 (Failure)

2013-05-21 13:31:50

<< PACKAGE LOG (SelfExtractable) >>

ate Package application started <===============

Command: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\s3jg\BIOS_VHP27_WN32_1.11.0.EXE

Date:  2013-05-21 13:31:50

=========================================================================
PackageReleaseId  Not Available
PackageState  complete
PackageStatus  5
TotalStatus  One or more Update Packages failed during execution, but the update continued running to the end.
TotalStatusMessage  Software update complete.

0 Kudos
14 Replies
8 Krypton

Re: OME System Update Failure

To troubleshoot the issue, create a separate system update task and select the two DUPS (BIOS, BroadCom NIC) mentioned above. Run the task against this target. After the task finishes, check if the system rebooted. Wait for 30 minutes and re-inventory the target from OME.

0 Kudos
jkazbill
6 Indium

Re: OME System Update Failure

Hey Raj,

I ran through the troubleshooting steps as you laid out and the task failed.  I set the task to automatically reboot the server if needed, but the server never did reboot.  I performed a discovery and inventory after 30 minutes on the server in OME and the two updates (BIOS and NIC firmware) still show as required.  The error messages for the update task are below.

Thanks,

Jason

 

PackageCode  1
PackageFileName  C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\s35g\BIOS_VHP27_WN32_1.11.0.EXE
PackageLog  << PACKAGE LOG (SelfExtractable) >>

wer than the currently installed version.

   Software application name: BIOS

   Package version: 1.11.0

   Installed version: 1.9.0

Executing update...

Device: BIOS, Application: BIOS

   doDepcheck failed

==============================> Update Result <==========================

Update was not applied

=========================================================================

Exit code = 1 (Failure)

2013-05-22 10:49:11

<< PACKAGE LOG (SelfExtractable) >>

ate Package application started <===============

Command: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\s35g\BIOS_VHP27_WN32_1.11.0.EXE

Date:  2013-05-22 10:49:11

=========================================================================
PackageReleaseId  Not Available
PackageState  complete
PackageStatus  5
PackageCode  1
PackageFileName  C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\s35g\Network_Firmware_H15FK_WN_7.2.20_A00.EXE
PackageLog  << PACKAGE LOG (SelfExtractable) >>

=======================> Update Result <==========================

Update was not applied

=========================================================================

Exit code = 1 (Failure)

2013-05-22 10:47:46

<< PACKAGE LOG (SelfExtractable) >>

==========
PackageReleaseId  Not Available
PackageState  complete
PackageStatus  5
TotalStatus  One or more Update Packages failed during execution, but the update continued running to the end.
TotalStatusMessage  Software update complete.

0 Kudos
8 Krypton

Re: OME System Update Failure

Dependency check failed for BIOS update when OME tried to apply it.

Can you manually copy and apply this update (BIOS_VHP27_WN32_1.11.0.EXE) on the system ?

0 Kudos
jkazbill
6 Indium

Re: OME System Update Failure

Yes, but I must ask, is this only for testing purposes?  Having to always do that greatly defeats the purpose of OME.

I'll test it now.

Thanks,

Jason

0 Kudos
8 Krypton

Re: OME System Update Failure

This is only for testing purposes to determine the root cause.

0 Kudos
jkazbill
6 Indium

Re: OME System Update Failure

Hey Raj,

I attempted to apply the BIOS update directly on the system, but I received the following error (see attached image).

0 Kudos
8 Krypton

Re: OME System Update Failure

Could you please attach the image again ?

0 Kudos
bigmikeh1965
6 Indium

Re: OME System Update Failure

I'm getting a failure on just the broadcom card across different servers. Network_Firmware_H15FK_WN_7.2.20_A00.EXE

PackageCode  1

PackageFileName  C:\Users\mhaas\AppData\Local\Temp\s3es\Network_Firmware_H15FK_WN_7.2.20_A00.EXE

PackageLog  << PACKAGE LOG (SelfExtractable) >>

==========> Update Result <==========================

Update was not applied

=========================================================================

Exit code = 1 (Failure)

2013-05-23 13:29:49

<< PACKAGE LOG (SelfExtractable) >>

Update Package finished.  Exit code = 1

PackageReleaseId  Not Available

PackageState  complete

PackageStatus  5

TotalStatus  One or more Update Packages failed during execution, but the update continued running to the end.

TotalStatusMessage  Software update complete.

<?xml version="1.0" encoding="UTF-8"?>

<?mso-application progid="Excel.Sheet"?>

<Workbook xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:x="urn:schemas-microsoft-com:office:excel" xmlns="urn:schemas-microsoft-com:office:spreadsheet">

<Styles>

<Style ss:ID="GeneralDate">

<NumberFormat ss:Format="General Date"/>

</Style>

</Styles>

<Worksheet ss:Name="Worksheet1">

<Table>

<Column ss:Width="126"></Column><Column ss:Width="95"></Column><Column ss:Width="115"></Column><Column ss:Width="314"></Column><Column ss:Width="60"></Column><Column ss:Width="124"></Column><Column ss:Width="146"></Column><Column ss:Width="126"></Column><Column ss:Width="279"></Column><Row>

<Cell ss:Index="1"><Data ss:Type="String">System Name</Data></Cell><Cell ss:Index="2"><Data ss:Type="String">Importance</Data></Cell><Cell ss:Index="3"><Data ss:Type="String">Update Method</Data></Cell><Cell ss:Index="4"><Data ss:Type="String">Component</Data></Cell><Cell ss:Index="5"><Data ss:Type="String">Type</Data></Cell><Cell ss:Index="6"><Data ss:Type="String">Installed Version</Data></Cell><Cell ss:Index="7"><Data ss:Type="String">Upgrade/Downgrade</Data></Cell><Cell ss:Index="8"><Data ss:Type="String">Available Version</Data></Cell><Cell ss:Index="9"><Data ss:Type="String">Package Name</Data></Cell></Row>

<Row>

<Cell  ss:Index="1"><Data ss:Type="String">tradc5.lr.k12.nj.us</Data></Cell><Cell  ss:Index="2"><Data ss:Type="String">Optional</Data></Cell><Cell  ss:Index="3"><Data ss:Type="String">OMSA</Data></Cell><Cell  ss:Index="4"><Data ss:Type="String">Broadcom NetXtreme I and NetXtreme II Driver Family</Data></Cell><Cell  ss:Index="5"><Data ss:Type="String">Driver</Data></Cell><Cell  ss:Index="6"><Data ss:Type="String">0</Data></Cell><Cell  ss:Index="7"><Data ss:Type="String">Upgrade</Data></Cell><Cell  ss:Index="8"><Data ss:Type="String">17.2.0</Data></Cell><Cell  ss:Index="9"><Data ss:Type="String">Network_Driver_H8HTP_WN32_17.2.0_A00.EXE</Data></Cell></Row>

<Row>

<Cell ss:Index="1"><Data ss:Type="String"></Data></Cell><Cell ss:Index="2"><Data ss:Type="String"></Data></Cell><Cell ss:Index="3"><Data ss:Type="String"></Data></Cell><Cell ss:Index="4"><Data ss:Type="String"></Data></Cell><Cell ss:Index="5"><Data ss:Type="String"></Data></Cell><Cell ss:Index="6"><Data ss:Type="String"></Data></Cell><Cell ss:Index="7"><Data ss:Type="String"></Data></Cell><Cell ss:Index="8"><Data ss:Type="String"></Data></Cell><Cell ss:Index="9"><Data ss:Type="String"></Data></Cell></Row>

</Table>

<AutoFilter x:Range="R1C1:R1C9" xmlns="urn:schemas-microsoft-com:office:excel"></AutoFilter>

</Worksheet>

</Workbook>

0 Kudos
bigmikeh1965
6 Indium

Re: OME System Update Failure

it successfully applied when ran locally.

0 Kudos