Highlighted

VMware ESX 4.x Inventory Issue

I must be doing something stupid...

We are running ESX 4.0 (not ESXi) and have installed OMSA 6.5 on all of our servers. I have configured SNMP on the ESX host servers and we are able to access the OMSA Web interface on all of the servers  so I know OMSA is installed properly. The issue is that in OME they show up as a VMware ESX Server but purple, it has some basic information (vm guests running) regarding the server but not the service tag, model, etc... So I am missing something here just not sure what.

Any input would be great?

Tags (3)
0 Kudos
18 Replies

Re: VMware ESX 4.x Inventory Issue

Hi Ron,

Setting ESX and ESXi up for management does take a bit of effort :-)

I meant to post a tutorial on this, so thanks for the reminder.  Have a look at this new thread and see if it helps.

Let me know,

Rob

en.community.dell.com/.../19433585.aspx

DELL-Rob C
Social Media Support
#IWork4Dell

0 Kudos

Re: VMware ESX 4.x Inventory Issue

I have that process already.....

I have installed OMSA with the -x switch to install everything and enabled the vnware firewall port 1311 to access the web console.

I have configured SNMP and tested it with the Dell Troubleshooting tool and it is configured properly.

After that I am stuck, I get minimal iformation about the servers, as I said no Dell specific info. Is there something else that neesd to be open in the ESX firewall cfg?

0 Kudos

Re: VMware ESX 4.x Inventory Issue

Thanks.

Just to confirm.  When you did the SNMP test in the TS tool, you saw the OMSA version return in the success message.  Is that correct?

Also a few other config items to review:

• chkconfig snmpd on

• Since SNMP is not started by default, this command ensures it will be started after a reboot of the ESX server.

• esxcfg-firewall –e snmpd

• This command line allows SNMP traffic through the built-in ESX firewall.

Rob

DELL-Rob C
Social Media Support
#IWork4Dell

0 Kudos

Re: VMware ESX 4.x Inventory Issue

We've also seen a reboot may be required as some of the omsa services don't always get started right (for whatever reason).

The TS results should look similar to below:

DELL-Rob C
Social Media Support
#IWork4Dell

0 Kudos

Re: VMware ESX 4.x Inventory Issue

Thank you for the pic of your TS, getting closer.

I dont see the Server Administrator or the Inventory Collector in my results for SNMP, Odd!!!

OMSA is fully installed, used the -x switch and I am able to access the OMSA web interface on the ESX hosts so I know its installed and working.

0 Kudos

Re: VMware ESX 4.x Inventory Issue

Ok, what about my post from 2:51pm?  Anything useful there?  Looks to be some last config item on ESX to iron out...hmmm...

DELL-Rob C
Social Media Support
#IWork4Dell

0 Kudos

Re: VMware ESX 4.x Inventory Issue

I did both of those command prior, sorry should have said that. I restarted the host server as well to get a clean restart and still the same.

0 Kudos

Re: VMware ESX 4.x Inventory Issue

A few other tips.  I think you've tried a few of these but I will include all for others.

1. Reboot target if not already done

2. Check snmp settings

 Check the SNMP settings as shown in the OMSA installer guide, Page 37 here:

<ADMIN NOTE: Broken link has been removed from this post by Dell>

3. Check omsa services running

[root@PE2950-ESX4U1 ~]# rpm -qa | grep srvadmin

srvadmin-storelib-6.3.0-233.1.vmw40

srvadmin-libxslt-1.1.17-10.1.vmw40

srvadmin-deng-6.3.0-64.1.vmw40

srvadmin-rac-components-6.3.0-224.2.vmw40

srvadmin-smcommon-6.3.0-233.1.vmw40

srvadmin-cm-6.3.0-2075

srvadmin-hapi-6.3.0-66.2.vmw40

srvadmin-megalib-6.3.0-1.329.el3

srvadmin-xmlsup-6.3.0-184.1.vmw40

srvadmin-omilcore-6.3.0-639.1.vmw40

srvadmin-omcommon-6.3.0-184.1.vmw40

srvadmin-omacore-6.3.0-184.1.vmw40

srvadmin-racdrsc-6.3.0-224.2.vmw40

srvadmin-racadm4-6.3.0-15.2.vmw40

srvadmin-jre-6.3.0-184.1.vmw40

srvadmin-smweb-6.3.0-233.1.vmw40

srvadmin-storage-6.3.0-233.1.el5

srvadmin-sysfsutils-6.3.0-7.2.el3

srvadmin-argtable2-6.3.0-9.1.vmw40

srvadmin-isvc-6.3.0-100.2.vmw40

srvadmin-racadm5-6.3.0-36.2.vmw40

srvadmin-iws-6.3.0-184.1.vmw40

srvadmin-storage-populator-6.3.0-233.1.el3

4. Uninstall OMSA, reboot, re-install OMSA, reboot, try t-shoot tool again

DELL-Rob C
Social Media Support
#IWork4Dell

0 Kudos

Re: VMware ESX 4.x Inventory Issue

Another tip from a buddy of mine...

If he is able to view the OMSA web console page for the ESX server, but not see the data in the TST, you may need to add the proxy line (step 2 below) in the snmpd.conf file….

To configure the proxy and enable the VMware SNMP agent

1 Stop the snmpd service through the service console on the ESX host.

service snmpd stop

2 Add a proxy line to /etc/snmp/snmpd.conf.

proxy -v 1 -c public udp:127.0.0.1:171 .1.3.6.1.4.1.6876

In this example, -v 1 reports the Net‐SNMP version to proxy, -c specifies the community string for

Net‐SNMP, udp:127.0.0.1:171 specifies the localhost IP address and the port number for the VMware

SNMP agent to proxy through. This example uses port 171 (you might choose a different port number).

The port number must be the same as the one you specify for the VMware SNMP agent, as described in

the next step. 1.3.6.1.4.1.6876 refers to the enterprise object identifier (OID) of the VMware MIBs.

3 Using the VMware vSphere™ CLI, configure /etc/vmware/snmp.xml to bind the VMware SNMP agent

to port 171 and start the service.

vicfg-snmp.pl --server <hostname|IP address> --username <username> --password <password> -E -c

public --port 171

In this example, -E enables the VMware SNMP agent, -c public sets communities to public, and

--port 171 changes the default port of the VMware SNMP agent to 171.

The command adds the following entries into /etc/vmware/snmp.xml (VMware recommends you use

the vicfg-snmp.pl command to change this file instead of editing the file itself):

<config>

<snmpSettings>

<communities>public</communities>

<enable>true</enable>

<port>171</port>

<targets>IP address@162 private</targets>

</snmpSettings>

</config>

4 Restart the mgmt‐vmware service (hostd) and the snmpd service. On the ESX host from the service

console, use these commands.

service mgmt-vmware restart

service snmpd restart

DELL-Rob C
Social Media Support
#IWork4Dell

0 Kudos