Highlighted
1 Copper

drm proxy settings with domain account

Hi,

how do I input the credentials for domain authenticated proxy server?

I have tried several inputs like domain\username, domain/username, domain\\username... but nothing seems to work.

When I check the drm logs there is always

Initializing DMSDownloader auth:DMSAuthParams [null/<string from input>] ...

Does the "null" represents a domain?

How do I change the "null" to some domain?

Thank you.

Labels (1)
0 Kudos
5 Replies
Highlighted
Moderator
Moderator

Re: drm proxy settings with domain account

Hi,

 

Would you be able to let me know how is the DRM setup on the network configuration? Also, what version are you on?

 

Have you tried without the domain, just username and password?


Thanks,
Joey Chong
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
Highlighted
1 Copper

Re: drm proxy settings with domain account

Hi,

I have tried user without domain too, but the windows server with drm 3.3.0.627 is not in the domain, so I have to somehow input the domain.

I use the command drm --set --proxy=http://<domain>\<user>:<password>@<proxy_ip>:<proxy_port>.

in the drm log there is the "null" instead of domain i suppose.

when I use only the user without domain i get proxy authentication error.

if I use the domain\user i get proxy parameter error.

Thank you.

0 Kudos
Highlighted
Moderator
Moderator

Re: drm proxy settings with domain account

Hello @NotSam,

 

Is the repository that you created on the same network as the servers that you are updating? The repositories can be stored in a local storage location, a mapped network shared location, or Common Internet File System (CIFS).

 

The DRM can run through a Proxy Server, but it need to be installed inside the firewall and connect to a catalog located outside the firewall (like a local repository or https://dell.to/3dT1gyQ) through a proxy server. You can use the proxy server settings of Internet Explorer. If the proxy settings for Internet Explorer are not working, the proxy can be set in DRM. You can then use Dell Repository Manager to customize the catalog as per the requirement and store the customized catalog inside the firewall.

 

In order to configure the Proxy Settings, you can do it in Manage / Application Preferences / Network and you must provide the Proxy Server Address, Proxy Port, and the appropriate credentials.

 

Please, let me know if this helps.
Regards.

logo
 Diego López
 
 Social Media and Communities Professional
 Comunidad Dell | @DellAyudaPro | Eventos en línea
0 Kudos
Highlighted
1 Copper

Re: drm proxy settings with domain account

Hi,

thank you for the explanation, I get that.

 

there is no problem with local network.

the problem is the username for proxy server authentication with domain account.

usually one can use domain\user string, but that is not accepted by drm settings.

does not matter if I input the string to gui field or use command line.

in drm logs there is always

"Initializing DMSDownloader auth:DMSAuthParams [null/<string from input>]..."

if I input domain\user string as username for proxy, there is log

"Initializing DMSDownloader auth:DMSAuthParams [null/domain\user]..."

if I input domain/user string, the log is

"Initializing DMSDownloader auth:DMSAuthParams [null/domain/user]..."

if I input user@domain, the log is

"Initializing DMSDownloader auth:DMSAuthParams [null/user@domain]..."

so I do not know what string I should use to make the proxy authentication to work.

 

but ok, I will use other proxy without authentication to avoid this issue.

Thank you.

0 Kudos
Highlighted
2 Bronze

Re: drm proxy settings with domain account

Hi,

Latest DRM version has fixes related to proxy, can you please upgrade and try establishing proxy connection  once before going with unauthenticated proxy method,

https://www.dell.com/support/home/en-us/drivers/DriversDetails?driverid=4d32v

Let us know if this resolved your issue.

Thanks,
Senthil
#Iwork4dell

0 Kudos