Highlighted
Not applicable

Can't use USB ports on optiplex 7040 before OS boots

I image all pcs that go out to our users with imagex.  I put the .wim file on external usb drive, boot to Win Pre-installation disk (that I made with my easy-to-use batch files) and copy the .wim file from usb drive to target machine - then apply.  I've been doing this for years on countless machines hp / dell / laptop / desktop / tablet / etc...  These optiplex 7040s that we just bought won't allow me to copy anything from usb to pc while booted to Preinstallation CD.  PC doesn't recognize anything that's plugged into usb ports (storage wise, that is.  keyboard, mouse work fine)  I can boot to usb - but then still can't see files that are on usb device i just booted!  USB ports work fine once os comes up.  They work fine for keyboard / mouse even when not in windows.  They work fine to boot from usb device.  In BIOS fastboot is off, all usb ports are enabled.  And I've pulled 3 separate brand new pcs out of the box and they all act the same.  Please help?

0 Kudos
8 Replies
Highlighted
5 Tungsten

RE: Can't use USB ports on optiplex 7040 before OS boots

I am by no means an expert, but this response will bump your question if my answers do not answer anything.

After reviewing the manual for your systems, I would make sure secure boot is off, make sure you are booting the USB via legacy options and not UEFI, and make sure the HDD/SSD is set to ACHI and not RAID, unless you need raid.

One thing that comes to mind is if your mini-windows program is loading the drivers correctly during boot for the Intel 6 Series processor and controllers?  I haven't done minwin or the like in a very long time so I am not sure how to update or reload minwin (or the like) for newer drivers, but I'm sure windows 7 by default doesn't have any driver support for 6th gen USB/Processor/etc., thus defaulting and that may cause an issue using USB as an actual drive after OS is loaded?  Take that one with a grain of salt btw since its just me thinking lol.  

Everything else should be fine in the BIOS/UEFI as long as legacy is used and secure boot is off.  

0 Kudos
Highlighted
Not applicable

RE: Can't use USB ports on optiplex 7040 before OS boots

I am having the same issue with OptiPlex 7040's we have.    I boot a window flash drive that has the usb 3.0 drivers and the mouse and keyboard does not work.   The same usb drive works fine on an OptiPlex 7440 AIO and I have used it to image 40 of those computers.  Is there a fix for this?   Does dell have a windows 7 bootable usb that works?

0 Kudos
Highlighted
5 Tungsten

RE: Can't use USB ports on optiplex 7040 before OS boots

Hello!  Not that I'm aware of, I think Dell started using the USB restore drives only a year or so ago so that would be for windows 8.1 and 10.  Even then i'm not sure if it would work until after driver installation in windows 7. Is there a reason you dont want to use USB 2 ports for your keyboard and mouse?  You should have at least 2 on the back.  

0 Kudos
Highlighted
2 Bronze

RE: Can't use USB ports on optiplex 7040 before OS boots

No, there are no USB 2 ports. Seems to be related to new Skylake "features" - there is no way to "disable" USB 3 functionality, which is available e.g. on Latitude E7450. There are some no-easy-to-run guides for deployments, which I have to go though, as nothing else works. All USB devices dont work after injecting official USB 3 drivers into boot.wim:2 (I tried multiple versions, even those from Intel). I tried official recovery image from the support page, which does not work either. 

0 Kudos
Highlighted
2 Bronze

RE: Can't use USB ports on optiplex 7040 before OS boots

Found the problem after 8 hours. BIOS version 1.0.1 was the issue. I had to download Windows 10 recovery image from Dell website (Windows 7 recovery image didn't work either), install Windows 10 (I thought about Hiren's boot CD as well - pretty much anything running 32 bit exe apps) and updated the BIOS. Since then, Windows 7 installation with injected USB3 drivers finally works (it at least offers the partion for installation, but I am keeping Windows 10).

0 Kudos
Highlighted
Not applicable

RE: Can't use USB ports on optiplex 7040 before OS boots

I m making a Win 7 image for my company for 7040 and once in audit mode my usb 2 doesn't work or 3..  I know 3 I need drivers.  But how can I get online no nic drivers.

0 Kudos
Highlighted
8 Xenon

RE: Can't use USB ports on optiplex 7040 before OS boots

There is support for this but its not free.

http://www.dell.com/downloads/global/services/ds_ximage.pdf

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
Highlighted
Not applicable

RE: Can't use USB ports on optiplex 7040 before OS boots

the only way out is to burn the app or data to a cd. That was how i installed or uploaded my stuffz

0 Kudos