Meroveus
1 Copper

Dell XPS 8900 Windows 7 and latest BIOS Update Computer Does Not Boot Windows

I bought a Dell XPS 8900 about a year ago and have had 0 issues with the setup. Tonight, the SupportAssist Dell App popped up saying my system needed critical system updates. Listed was a BIOS update (don't recall the version number). I let it install and update the BIOS but now my computer goes from the black and white DELL logo screen to a support assist white screen that appears because I have removed a fan in order to install a Radeon Fury X. I usually have to hit escape from that screen to load windows but instead the boot process starts all over again and I go back to the black and white DELL logo screen and the process stays in this endless loop. I have loaded the BIOS options and it says 2.1.10 as the BIOS version. I have tried to both use BIOS restore and Downgrade BIOS but nothing works and my system refuses to boot Windows. Is there an older BIOS version I can manually flash to correct this issue? I have had no issues with anything prior to updating the BIOS so can only assume that is the culprit. Perhaps an incorrect or corrupt BIOS upgrade? I let the computer do its thing and had no power outage, <profanity> thing just refuses to boot Windows. I cannot even get safe mode to come up (if I am using the proper keyboard command that is).

0 Kudos
4 Replies
RoHe
6 Indium

RE: Dell XPS 8900 Windows 7 and latest BIOS Update Computer Does Not Boot Windows

Did you try resetting BIOS by removing the motherboard battery and pressing/holding the power button for ~30 sec before reinstalling the battery?

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
michael2415
1 Nickel

RE: Dell XPS 8900 Windows 7 and latest BIOS Update Computer Does Not Boot Windows

I recently upgrade my BIOS to 2.1.10 for XPS 8900, works without a problem. I have an aftermarket graphic card on this as well. Try reseating the graphic card, making sure all the connections are okay. Reset your boot order or BIOS to factory settings and see if that helps.

0 Kudos
speedstep
6 Thallium

RE: Dell XPS 8900 Windows 7 and latest BIOS Update Computer Does Not Boot Windows

Secure Boot must be OFF and LEGACY Option Roms and CSM must be ON in order to post with NON DELL video card. When installing an after-market graphics card into a certified Windows PC with UEFI enabled, the system may not POST or boot.

http://nvidia.custhelp.com/app/answers/detail/a_id/3156/

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

Highlighted
Meroveus
1 Copper

RE: Dell XPS 8900 Windows 7 and latest BIOS Update Computer Does Not Boot Windows

Yeah, I took the card out and re-seated. It was my mistake for trying to enable SafeBoot. Tried removing battery and ensuring power down on power button for 15 seconds at least. Got Safeboot disabled and computer loads past Dell logo but having trouble locating HD now. Still working on it but almost there. Never downloading a BIOS update again.

0 Kudos