Qbaron
1 Copper

Graphics card not detected!

Hello! 

I have a dell optiplex 990 MT (i5 2500,4GB,windows 10) and I decided to upgrade it so I bought and installed a Gainward GTX 1050 (2GB) and a Corsair VS550. When I boot up my computer, all fans are spinning (that means the card is installed properly because it only receives power from the motherboard) but I have no display.(connected monitor to new gpu). When I connect the monitor to onboard graphics (intel hd grpahics), everything works fine. In the section "display adaptors" in device manager, it only shows "Intel HD Graphics". I cannot install the gpu drivers because the card is not detected. Everything is updated in the computer. Bios is A19. I have been told that onboard graphics are disabled when bios detects an external graphics card.

How can I solve this problem?

0 Kudos
4 Replies
8 Xenon

RE: Graphics card not detected!

Most of the newer nVidia and AMD video cards - the GTX 10x0 and AMD 4xx and higher - require that the system be in UEFI mode -- is your system using UEFI or legacy BIOS mode?

If it's in legacy BIOS mode, you'll need to change it over to UEFI (which will in turn require a complete reinstall of  a 64-bit version of Windows, 7 8 or 10).

0 Kudos
7- Thorium

RE: Graphics card not detected!

You have to turn CSM ON and Secure Boot OFF in order to use newer cards like the GTX 1050.

Please ensure that BIOS version A19 or newer is installed on the Optiplex 790 or 990 prior to the install.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

Qbaron
1 Copper

RE: Graphics card not detected!

I haven't tried to turn CSM ON and Secure Boot OFF because I don't know how. Can you help me? Bios is updated to A19.

0 Kudos
8 Xenon

RE: Graphics card not detected!

If the system were now in UEFI mode, the card should work without issue.  If it's in legacy BIOS mode (setup - F2 at powerup -- will tell you), the VERY FIRST thing to do is make a complete backup of your data.  If you change the system to full UEFI mode, you will need to completely reinstall Windows.  There is an intermediate option that should work without a reload - key word should, but it's not guaranteed.  Set the system setup to UEFI mode with legacy option ROMs on - you may be able to get the system to start without reloading.  If you can't, you'll need to proceed with UEFI mode and a complete reload of the OS, software, drivers and data.  You must be running 64-bit WIndows 7, 8 or 10 to use UEFI mode - it WILL NOT work with 32-bit Windows.

0 Kudos