Highlighted
Aethir
1 Copper

Help! X-Fi not recognised under XP, and onboard won't re-install?!

Hi 🙂

just wondering if someone can help with what's proving to be a hellish annoying problem...

 

my g'f owns an Inspiron 1100 (the 2.5GHz Celery model) with onboard audio (Dell mobo #OWF887, A01)

As an early xmas present, I bought her a retail PCI Creative X-FI Xtreme Audio card (Model # SB0792).

After disabling the onboard audio and installing the card, lo and behold, the card wasn't recognized, at all. Changing slots didn't help.

So, my g'f removed the Creative and re-enabled the onboard...

...and now the system THINKS the Creative card is there, but the driver install (obviously) finds no compatible hardware;

...and the onboard isn't detecting, with similar driver install failures.

 

Has this ever happened to anyone else? I know there's issues with X-FI and Vista/W7 - but this is an XP install!

It's incredible frustrating, and to be honest has me baffled, and I've built and worked on systems for a number of years.

0 Kudos
3 Replies
fireberd
6 Indium

Re: Help! X-Fi not recognised under XP, and onboard won't re-install?!

It could all be a BIOS problem.  Reset the CMOS (BIOS) and see if that helps things.  With the PC powered off, remove the CR2032 CMOS backup battery on the motherboard for about 10 minutes.  Reinstall and see if Windows sees the on-board audio again.  If not, reinstall the Intel motherboard chipset drivers and then restart the PC and check the audio again.     If this all works, since the BIOS was reset and the chipset drivers were reinstalled, try the Xfi card again. 

One of the prime things the chipset drivers do is define (identify) the devices on or attached to the motherboard. 



I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 - 5577 Laptop

Home Built Desktop PC with ASUS ROG Z170, i7 6700K CPU

Windows 10 64 bit Pro and Windows 10 Insider Program Beta Versions. SSD drives. Cakewalk by BandLab and Studio One 4.1 Recordng Studio Software.

Dell S2719dgf Monitor

Member of Nashville based R.O.P.E.

0 Kudos
Aethir
1 Copper

Re: Help! X-Fi not recognised under XP, and onboard won't re-install?!

Awesome! I have onboard back 🙂

Now to try the X-Fi again... would it be worthwhile physically installing the card and then re-installing the chipset drivers again, to see if that helps?

 

Thanks heaps for the help, I was going spare.

 

0 Kudos
fireberd
6 Indium

Re: Help! X-Fi not recognised under XP, and onboard won't re-install?!

I would first just try the Xfi and if it still doesn't work then try reinstalling the chipset drivers. 



I am not a Dell Employee

Dell forum member since 2002

Dell Inspiron 15 - 5577 Laptop

Home Built Desktop PC with ASUS ROG Z170, i7 6700K CPU

Windows 10 64 bit Pro and Windows 10 Insider Program Beta Versions. SSD drives. Cakewalk by BandLab and Studio One 4.1 Recordng Studio Software.

Dell S2719dgf Monitor

Member of Nashville based R.O.P.E.

0 Kudos