Beber
2 Bronze

How can I use SATA 2 & 3 in an Optiplex 330 ?

Whatever I plug into one of these ports is recognized properly in BIOS (version A11 now, but was the same with version A03 or A09), but not in Windows XP.

Here, I can't find the  CD-ROM plugged in SATA2 (disc tray opens when I press the button), just the two HDDs plugged in ports SATA 0 & 1:

Disk manager :

Are ports SATA2 & 3 really active on this computer ? BIOS does identify properly the CD-ROM. CD-ROM plugged in SATA1 will work under XP.

Thank you for reading

0 Kudos
5 Replies
rdunnill
6 Indium

RE: How can I use SATA 2 & 3 in an Optiplex 330 ?

Did you activate the ports in the BIOS setup?

0 Kudos
Beber
2 Bronze

RE: How can I use SATA 2 & 3 in an Optiplex 330 ?

Yes, and whatever is plugged in will appear correctly in BIOS when the port setting is "ON".

0 Kudos
rdunnill
6 Indium

RE: How can I use SATA 2 & 3 in an Optiplex 330 ?

It doesn't sound like they're active, then.

A third-party SATA card can get around this problem.

0 Kudos
Beber
2 Bronze

RE: How can I use SATA 2 & 3 in an Optiplex 330 ?

I'll probably keep on plugging the cd-rom in sata1 on the rare occasions I need it.

Dell seems quite pleased to mention these ports on the manual, what's the point if they can't be of any use ?

Thanks for your help, anyway.

0 Kudos
Beber
2 Bronze

RE: How can I use SATA 2 & 3 in an Optiplex 330 ?

Actually, ports are active : I can boot from a CD (plugged in SATA2) and access the disks plugged in 0 & 1.

It seems then to be a windows XP problem ? What could be missing from my installation to let windows see those ports ?

In the Hardware Manager shown above, where should the CD-ROM appear ?

0 Kudos