smr1954
1 Copper

Invalid service tag

I purchased a studio XPS computer from Dell in July and was just going to check
to see if there were any upgrades to drivers software etc. So I went to my
account and clicked on my service tag under my account and it brings me to a completely
different computer with a different service tag. So I go to manually put my
number in and it says invalid service tag. So i checked my Bios and the back of
machine and I do have the correct service tag. Next I try to Email for help but
of course it asks me for my service tag which is invalid so I can go no further.
Next I try online support and it tells me my system was purchased from another
country ( I am from US) so I have no online US support. Does anyone have any idea
what i can do. I see no other way of contacting customer support without a
valid service code.

0 Kudos
6 Replies
jackshack
5 Tungsten

Re: Invalid service tag

Was the computer purchased directly from Dell, or was it purchased from a local store?  If it was a local purchase it is necessary to register the computer to have it recognized by Dell.  One way to do that is here:  Dell Product Registration.


Dell Forum member since 2005

0 Kudos
smr1954
1 Copper

Re: Invalid service tag

it was purchased from dell and it was already in my profile it shows when I bought it my service tag and warranty information

0 Kudos
7 Plutonium

Re: Invalid service tag

smr1954

Try phoning Dell's Customer Service HERE

Bev.

 


If my answer was helpful, please click: Kudos
Forum Member since 2001
I am not employed by Dell

0 Kudos
smr1954
1 Copper

Re: Invalid service tag

Well it is working now I was about to call per suggestion from shesagordie  but it seems to be working now. The only thing I did was reregister my system that JackShack suggested and that seemed to do the trick. Thanks to all who helped and hopefully this will help anybody else with the same problem.

0 Kudos
7 Plutonium

Re: Invalid service tag

smr1954

You are welcome and happy to hear the issue is resolved.

Bev.

 


If my answer was helpful, please click: Kudos
Forum Member since 2001
I am not employed by Dell

0 Kudos
RoHe
6 Thallium

Re: Invalid service tag

The Dell site was having troubles with Service Tags (and other things!) over the weekend so that might have been the real problem.

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos