DumbDan
2 Iron

Lost my center Speaker On XPS 600 Help Needed PLEASE!!!

Hello it's been many moons since I have been here, or needed to be here.  But I find myself in need of some assistance.

I can't seem to get any sound from my center speaker.  I'm not sure if my profile still has my system info but I will post it anyway.

Logitech Z5500 speakers.

Creative Soundblaster XFI extreme sound card.

It's been so long since I have poked around in my system I don't remember what is what or where.  I do know that the speaker does work when I connect the wire to a different channel on the sub woofer.  But other that that I can't seem to get any noise to come out when I play music or movies.  Just a dead speaker.  I use Widows Media Player.  I have not taken any driver downloads in years.  I just take what comes to me from MSN via automatic updates.  Any help would make me a happier person when I am sitting at the desk, which is always.

 

Thanks DumbDan

0 Kudos
2 Replies
DumbDan
2 Iron

Re: Lost my center Speaker On XPS 600 Help Needed PLEASE!!!

Okay so when I go to the THX console to check the polarity it gives me an error message that says........

erroe loading wave files please reinstall the THX setup console.  How do I do that?  I will try to get that done.

0 Kudos
Highlighted
Toronto699
4 Tellurium

Re: Lost my center Speaker On XPS 600 Help Needed PLEASE!!!

http://support.creative.com/downloads/welcome.aspx

install the 2.18.0008 driver dec 17/08

install the Console launcher 2.60.35 jan 7/09

install creative media source 5 player/organizer 5.25.02 feb 7/09

i would also install any of the latest software apps just check the dates.

after u  install the driver u may have to select your speakers as 5.1 in the volume control panel in entertainment mode. also  in the speaker selection select , advanced ,  to make sure all the channel volumes are up such as front left ,front rt , front center, rear left , rear rt. hope this helps  http://www.creative.com/products/soundblaster/howto/?c=1&t=1

http://forums.logitech.com/logitech/board?board.id=51_speakers

 

 

0 Kudos