Highlighted
8 Krypton

My DELL Inspiron 530s is not detecting the mouse at startup amd possibly the keyboard; how do I fix this?

When the power button is pushed, you see a black screen with the dell logo, that changes really quick to the black screen with the green lines moving like it is loading and below those green moving lines it has the copyright Microsoft Corporation. It takes about a minute for that to change and goes to a black screen which takes about a minute to change to the password screen. That is just too slow starting up, it was working faster than this yesterday. You can see the nouse cursor blinking in the password box but you can't move the cursor it stays froze on the picture above the password box and you can't type anything. I can start in F2 mode, F12 mode and F8 which is safe mode. The keyboard works in those modes. If you start in safe mode it still does the same thing. I booted from CD ROM and I could use the mouse with no problem when it came to the keyboard and language settings. Start up repair could not detect a problem. Memory coukd not detect a problem. Could the operating system be corrupted and I need to reformat the hard drive and reinstall Windows Vista Home Basic? Thanks in advance for any help.
0 Kudos
1 Reply
8 Krypton

RE: My DELL Inspiron 530s is not detecting the mouse at startup amd possibly the keyboard; how do I fix this?

Hi Angela,

I don't think you have a mouse or keyboard problem. More likely to be a hard drive or operating system issue. My suggestion is to boot to your Dell drivers and utilities disc, and run the Dell diagnostics on your desktop. Specifically, you should test the hard drive. Let me know if you get any errors or other issues show up.

0 Kudos