Highlighted
NOaMTL
1 Nickel

No ACHI on Studio XPS 435 MT (2009) ?

I just had a SSD for my birthday, i plugged it right, but when i use the Performance Tool of the SSD, the speed is very low. I checked on internet and people saying I have to activate the driver through regedit (i did it). But when i look at the BIOS I have only 2 choices : ATA / RAID.... no ACHI. Any idea ? (please don't tell me i have to change my motherboard).

0 Kudos
8 Replies
8 Krypton

Re: No ACHI on Studio XPS 435 MT (2009) ?

You need to select Raid.  This will enable ACHI on the SATA ports.  You need to do this before the operating system is installed on the new SSD.  

0 Kudos
NOaMTL
1 Nickel

Re: No ACHI on Studio XPS 435 MT (2009) ?

Thank you for your answer. But when i want to choose RAID, i have to select 2 disks minimum... (is it because windows is installed on the new SSD ?) (and i got 2HHD without windows installed on it)

0 Kudos
8 Krypton

Re: No ACHI on Studio XPS 435 MT (2009) ?

Yes.  You will need to reinstall windows on the SSD after selecting Raid.  

0 Kudos
8 Krypton

Re: No ACHI on Studio XPS 435 MT (2009) ?

Hi NOaMTL,

You can select RAID for the controller mode with a single hard drive. It's not necessary to set up an actual RAID disk array.

0 Kudos
NOaMTL
1 Nickel

Re: No ACHI on Studio XPS 435 MT (2009) ?

Hi,

I tested few things :

- I tried to safe erase my SSD to become out-of-the-box but no success, with samsung magician, so i used the windows tool to remove partition. (i tried the following things with the SSD with partition and without (but no OS on it))

- I plugged only my SSD and CD/DVD on sata ports

- Tried to turn RAID, but can't

- Tried to plug others disks (HDDs) and i can RAID with 2 disks minimum

conclusion : I don't know why, I can't put RAID for my new SSD (i tried on others HDDs too, same issue, 2 devices minimum)

Thanks again for helping me.

0 Kudos
8 Krypton

Re: No ACHI on Studio XPS 435 MT (2009) ?

Just to be sure we're talking about the same thing, you should be looking in the BIOS (F2) for this setting, not the Intel RAID  BIOS (Ctrl-i).

0 Kudos
NOaMTL
1 Nickel

Re: No ACHI on Studio XPS 435 MT (2009) ?

I pressed F2 to change the controler ata to RAID, then i presses Ctrl-i to create the "RAID SSD".

0 Kudos
NOaMTL
1 Nickel

Re: No ACHI on Studio XPS 435 MT (2009) ?

this time i didnt press CTRL-i, but i cant install windows on the SSD... im trying to safe erase it, but it is "frozen"... will give more infos soon

0 Kudos