Highlighted
lewwarren
1 Copper

No Sound XPS420 after HD crash/replacement

I replaced my HD after a crash. I installed Windows 7 Ultimate 64-bit to the new HD, before reloading my files from a backup drive. I thought everything was alright, until I noticed I had no sound.

I am wondering, does it have something to do with the fact that originally the Dell XPS420 came loaded with Windows XP-32bit? I have heard or read that SigTel was bought out by another company and that company's updates are not backward compatible with the older sound drivers. The XPS420 came with a MU508 Bose speaker system. I can get some humming noise when moving the cable connection, but it stops once the cable is seated properly. I cannot seem to locate the drivers that came with the original installation, which I would like to reload. I have tried installing some drivers, but receive a notice that it is not compatible.

I am becoming very frustrated! I will appreciate any help in resolving my dilemma.


Thank you in advance.

Lew

0 Kudos
4 Replies
8 Krypton

RE: No Sound XPS420 after HD crash/replacement

There are no Windows 7 or 8 drivers which means you must use WDDM 1.0 Vista Drivers.

sigmatel_stac-92xx-c-major-h_a06_r182475.exe

Sigmatel STAC 92XX C-Major HD Audio Driver A06

You should also Enable DOTNET 2.0/3.5 and install Directx JUNE 2010 BEFORE installing this driver. As they are dependencies on the driver working. Control Panel, All Control Panels, Enable features in windows.

You download the patch and Extract into a FOLDER then run DXSETUP.EXE

http://www.microsoft.com/en-us/download/details.aspx?id=8109

A square is not installed expand and check both check boxes to get a check and not square in the features.


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

lewwarren
1 Copper

RE: No Sound XPS420 after HD crash/replacement

SpeedStep,

Thank you very much for your reply. I now have sound. However, I cannot seem to get the sub-woofer to work at the same time as the L R speakers. I tried each of the outlets, but could not get them to work at the same time/setting. I am very grateful to at least have sound back.

Thank you!


LewWarren

0 Kudos
8 Krypton

RE: No Sound XPS420 after HD crash/replacement

I have heard or read that SigTel was bought out by another company and that company's updates are not backward compatible with the older sound drivers.

Microsoft provides Windows 7 and 8 drivers for Sigmatel audio. Case in point: my Dimension 3100 has Sigmatel audio, and the driver was installed automatically with Windows 8. 

Windows Catalog Sigmatel drivers

0 Kudos
8 Krypton

RE: No Sound XPS420 after HD crash/replacement

With windows 7 however they are not auto detected so they dont get updated until you install the wddm 1.0 drivers. SIGMATEL is also Sometimes Identified as IDT which I don't know if its the new or older vendor.

SigmaTel High Definition Audio CODEC

SigmaTel Stac 92XX

64 BIT

http://catalog.update.microsoft.com/v7/site/ScopedViewInline.aspx?updateid=f44c1e81-8723-4b99-8639-f...

 32 BIT

http://catalog.update.microsoft.com/v7/site/ScopedViewInline.aspx?updateid=6a05f964-475f-4d92-ba18-f...

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos