SuperMoe
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

My guys had been blaming my imaging load! I'll let you knwo what we hear from them.

0 Kudos
TiffanydOKC
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

I addded a step to my SCCM task sequence to install the Intel driver package on the 9020s only (used a WMI condition to query for the model) Then added another conditional step to configure the settings. Used Intel driver version 12.6.47. There's a vbscript with the driver that you can use to configure the NIC. You run it on a PC with the configuration you want to export. And save the settings to a text file, then run the import as a program in the package.

http://www.intel.com/support/network/sb/CS-028693.htm

 

This is what I have in my config file. You can see if it works for you.

 

*** NCS2 DMiX Save Data ***

*** Date 10/21/2013 Time 3:11:42 PM ***

**********************************************

 

OEMCustomizeable=

OS=6.1

 

Adapter Name=Intel(R) Ethernet Connection I217-LM

Adapter PCIDeviceID=VEN_8086&DEV_153a&SUBSYS_102805a4&REV_04&0&c8

Adapter BusDeviceFunction=0:25:0:0

Adapter Index=1

Private Description=

Adapter Capabilities=32,33,34,43,59,42,36,37,60,46,71,61,3,41,47,50,56,37,71,12,5,4

Description=Intel(R) Ethernet Connection I217-LM

setting Name=*FlowControl

setting Current Value=3

setting Description=Flow Control

setting Name=*JumboPacket

setting Current Value=1514

setting Description=Jumbo Packet

setting Name=*PMARPOffload

setting Current Value=0

setting Description=Protocol ARP Offload

setting Name=*PMNSOffload

setting Current Value=0

setting Description=Protocol NS Offload

setting Name=*PriorityVLANTag

setting Current Value=3

setting Description=Priority & VLAN

setting Name=*SpeedDuplex

setting Current Value=0

setting Description=Speed & Duplex

setting Name=*WakeOnMagicPacket

setting Current Value=1

setting Description=Wake on Magic Packet

setting Name=*WakeOnPattern

setting Current Value=1

setting Description=Wake on Pattern Match

setting Name=EEELinkAdvertisement

setting Current Value=0

setting Description=Energy Efficient Ethernet

setting Name=SipsEnabled

setting Current Value=0

setting Description=Reduce link speed during system idle

setting Name=EnableDHCP

setting Current Value=1

setting Description=StaticIP

setting Name=NetbiosOptions

setting Current Value=0

setting Description=StaticIP

setting Name=ConnectionName

setting Current Value=Local Area Connection

setting Description=ConnectionName

setting Name=EnablePME

setting Current Value=1

setting Description=Wake on Magic Packet from power off state

setting Name=ReduceSpeedOnPowerDown

setting Current Value=0

setting Description=Reduce link speed during standby

 

0 Kudos
SuperMoe
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

So this is what worked for us, the REG in this article:

https://communities.intel.com/thread/48210

Which is this:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

"LinkNegotiationProcess"="2"

 

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

"LinkNegotiationProcess"="2"

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

"LinkNegotiationProcess"="2"

 This is working on our 9020's with i217LM chipset.

 

0 Kudos
Jerico_99
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

We've got the same issue happening with Lenovo machines. We disabled vPro first, that didn't fix it. Then we unbound ipv6 from all the nics; That almost worked but some of the machines have on-board WiFi as well so those machines started flooding the network again. We've just unbound ipv6 on both the nic as well as the WiFi and unchecked power management settings.


So do I have this right in assuming that it's safe to have ipv6 bound to the nic as long as the power management features are all disabled in the adapter configuration?

0 Kudos
balkanman
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Hello, have you tried what I suggested in my earlier post which is to disable AMT in bios? Once we disabled it, everything works fine....power settings enabled, ipv6 enabled no problem. AMT starts multicasting from every pc and causes the traffic. Disabling this is what you nedd.

0 Kudos
Highlighted
Jerico_99
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

I'm going to coin this the "NOES (Nightmare on Elm Street)" bug.

I'll tell you what's really interesting about what we have found. Yes, AMT was the first thing that was disabled on all the PCs that were flooding the network; and the problem seemed to be mitigated for as long as "every single computer" had AMT disabled.

However, once we left "one" new computer on the network without disabling AMT (call him Freddy), that computer, once asleep, would enter the dreams of all of the sleeping "AMT Disabled" computers and scare them all into flooding the network again.

So it appears that there is something that AMT does that "triggers" the multicast flooding and then, as another poster put it somewhere else on the internet, "goads" the rest of the hosts to join in the flooding song, thus generating a DOS attack on the entire LAN subnet.

All the packets I've seen so far have a common thread in that they have to do with some sort of zero configuration feature. CAPWAP packets were flooding the network at one point. So this tells me that the bug could be the integration piece between wake on lan, magic packets, and ipv6 auto provisioning features within AMT.

Being that part of vPro architecture is that it acts as an internal switch within the P.C. itself, it seems as if this switch is looping ipv6 internally. One of the other posts i found online in regards to ipv6 looping indicated that some hypervisors running in windows were causing looping with ipv6 multicast because the traffic was bridging through the virtual adapters in the hypervisor.

So one theory I have is that these computers could be internally looping packets of the zero configuration type. The hypervisor technology within the vPro/AMT internal network has to have bridging interfaces for each network/Wi-Fi adapter available to windows in order to perform its duties as an agent. I don't know how many virtual adapters exist in a vPro/AMT v-switch but it's definitely more than one. If each of these or any of these internal interfaces has ipv6 multicast forwarding enabled, even if it’s only allowing certain types of packets through the filter, a looping situation would be immanent. And since there is no IP_ID in the header of ipv6 packets, it's impossible to tell with a packet capture that these are duplicate packets.

Also, since the computers are flooding zero-configuration type traffic, i'm wondering if another workaround would be to setup an ipv6 DHCP scope so these computers never try and configure themselves in such fashion (again I stress the word “workaround”).

Does anyone that has this problem actually have a working ipv6 dhcp server on their LAN?

0 Kudos
Mark Goldhamer
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

The traffic that is occurring when the device goes to sleep appears to be a faulty handling ot the Energy Efficient Ethernet feature.  BIOS versions A02 and prior seem to have the problem.  A03 doesn't seem to but as mentioned elsewhere is unstable.  A05 is the current version and that seems to stop the problem.  Visually, the Ethernet lights will be out when asleep instead of on.

My understanding of how the mess works is that the device, when asleep, sents something out to an unknown address that turns that into a multicast.  This reoccurs thousands of times per second.  By itself, a single device might only degrade your network.  For us, when we had 3 devices asleep at the same time the switch and adjacent router were overwhelmed.  The router failed over to the redundant router which then also failed back to the orginal router and on and on.  Waking up the devices stops the noise.  Disabling the EEELinkAdvertisement (1 to 0 in a few places in the registry) also seemed to shut the device up, but the BIOS update seems like the right answer.

Remember, if you have Bitlocker protection for your drive to disable Bitlocker before doing the BIOS update or you will be looking for your encryption key.

manage-bde -protectors -disable c  (as admin in a DOS window)

I think the M4800 has the same NIC.  I'm not sure if there are good and bad BIOS versions for it.

0 Kudos
chiners_68
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Hi All,

  we have been experiencing strange network issues. My collegues used a fluke to identify high traffink talkers which turned out to be OptiPlex 9020 AIO's using the I217-LM network card. I use the dell Cab files for the drivers & checked both A01 & A03 which both comntained driver version 12.6.47.0. I upgraded the drivers via windows update which went to v12.11.77.0 which was released 11/02/14. Once this was applied & the machines shut down they then dropped of from being a high talker on our network.

 

So windows update network drivers seems to resolve the issue

0 Kudos

RE: Opti 9020s with Intel I217-LM nics causing network issues

Little late to this party; we're planning to roll out hundreds of 9020s in the next few months but our first batch have network issues. Less of the broadcast storm described here, more not networking at all. I think our switches might be shutting them down as soon as they start -- has anyone experienced anything similar?

0 Kudos
Sahay
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Please retest using LAN driver version 19,0 available from the Intel support web site. Thanks!

0 Kudos